[Frage] Bootstrap 4 Dropdown & TypoScript TYPO3-Version: 8.7.12

  • KenjiKenTV KenjiKenT...
    Jar Jar Binks
    0 x
    1 Beiträge
    0 Hilfreiche Beiträge
    18. 04. 2018, 13:29

    Guten Tag,

    ich hoffe ich bin hier mit meinen Anliegen richtig.. :)

    Folgendes:
    Ich habe mit TypoScript dass Problem, dass die Dropdowns der Navpunkte nicht funktionieren geschweige denn generiert (nennt man das so?) werden. Er zeigt in der Navigation zwar an, dass es sich bei den Punkt um ein Dropdown handelt, aber mehr auch nicht..

    So sieht mein TypoScript aus:
    [code]menuPrimary = HMENU
    menuPrimary {
    special = directory
    special.value = 2
    wrap = <ul class="navbar-nav ml-auto">|<ul>
    1 = TMENU
    1 {
    NO = 1
    NO {
    wrapItemAndSub = <li class="nav-item">|<li>
    ATagParams = class="nav-link"
    }

    ACT < .NO
    ACT {
    wrapItemAndSub = <li class="nav-item active">|</li>
    }

    IFSUB < .NO
    IFSUB {
    wrapItemAndSub = <li class="nav-item dropdown">|</li>
    ATagParams = class="nav-link dropdown-toggle" role="button" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"
    ATagBeforeWrap = 1
    }
    ACTIFSUB < .IFSUB
    ACTIFSUB {
    wrapItemAndSub = <div class="dropdown-menu">|</div>
    ATagParams = class="dropdown-item"
    }
    }

    2 < .1
    2 {
    wrap = <div class="dropdown-menu">|</div>
    }
    }
    [/code]

    Umsetzen will ich das ganze in Bootstrap 4. Auch das JS funktioniert, da er versucht was anzuzeigen, es ist nur leider nichts da, was er dann anzeigen könnte..

    Weis jemand wo genau mein Fehler ist?


  • 1
  • Norman2k Norman2k
    Jedi-General
    0 x
    1650 Beiträge
    76 Hilfreiche Beiträge
    18. 04. 2018, 15:39

    Nur kurz überflogen, auf jeden Fall fehlt dir noch ein expAll = 1 in deinem TMENU

  • 1