[Frage] content-id vergeben TYPO3-Version: 8.7.6

  • daniekortvelyessy daniekort...
    Jar Jar Binks
    0 x
    1 Beiträge
    0 Hilfreiche Beiträge
    11. 09. 2017, 18:10

    Guude!

    ich habe mir als Typo3-Neuling die MASK EXT aufgespielt und ein wenig herum-probiert. Jetzt wollt eich ein TBS feature einbauen und habe dazu die MASK mit einem einfachem image und bodytex - Element angelegt.

    [code]<f:if condition="{data.image}">
    <f:for each="{data.image}" as="file">
    <f:image image="{file}" alt="{file.alternative}" title="{file.title}" width="200" /><br />
    {file.description} / {file.identifier}<br />
    </f:for>
    </f:if>

    <f:if condition="{data.bodytext}">
    <f:format.nl2br>{data.bodytext}</f:format.nl2br><br />
    </f:if>
    [/code]

    Das Temp habe ich dann entsprechend angepasst zu

    [code]<div class="row featurette row-eq-height">

    <div class="col-md-7">
    <f:if condition="{data.bodytext}">
    <f:format.html parseFuncTSPath="lib.parseFunc_RTE">{data.bodytext}</f:format.html><br />
    </f:if>
    </div>
    <div class="col-md-5 feat-r hidden-xs">
    <f:if condition="{data.image}">
    <f:for each="{data.image}" as="file">
    <f:image image="{file}" alt="{file.alternative}" title="{file.title}" class="img-responsive" />
    </f:for>
    </f:if>
    </div>
    </div>[/code]

    Dies wird nun fein gerendert, jedoch fehlt die content-id auf die ich verweisen möchte. Da ich diese nicht im Temp habe müsste ich ja das Feld angeben (sprich im ersten DIV ein id="{toller.code}", oder macht dies MASK automatisch und ich habe es durch die Änderung am Temp zerstört?

    Über den f:debug konnte ich kein Feld mit den id's finden auf das ich per Script zugreifen könnte...

    Wie schon, gesagt, als Neuling bin ich noch nicht allzu fest in dem Thema :/

    Für Hinweise (ich lerne sehr gerne dazu) wäre ich sehr dankbar :)

    LG, Daniel


  • 1
  • 1