[Frage] Frage zu tt_content im typoscript TYPO3-Version: 7.6.21

  • fahn fahn
    Padawan
    0 x
    54 Beiträge
    2 Hilfreiche Beiträge
    31. 08. 2017, 19:40

    Hey Leute,
    ich habe im typoscript eine tt_content auf gewissen Record auf die Tabelle tt_address gemacht.
    Hier erst einmal mein Code:
    [code]// https://stackoverflow.com/questions/18961580/the-detailed-view-of-the-last-item-of-a-list-build-by-typoscript-is-always-blank
    lib.membersList = CONTENT
    lib.membersList {
    table = tt_address
    select{
    pidInList = {$cc.tt_address.pid}
    join = sys_category_record_mm ON tt_address.uid = sys_category_record_mm.uid_foreign
    orderBy = name
    where = sys_category_record_mm.uid_local = {$cc.tt_address.cat.pid}
    }

    wrap = <div class="wtdirectory_list wtdirectory_list_wrap">|</div>

    renderObj = COA
    renderObj {
    10 = FLUIDTEMPLATE
    10 {
    file = {$cc.tmpl.list}

    variables {
    name = TEXT
    name {
    field = name
    }
    }
    }
    }

    #
    # DETAILS
    #
    stdWrap.override.cObject = CONTENT
    stdWrap.override.cObject {
    table = tt_address
    select {
    andWhere.data = GP:ts_addresslist|showUid
    andWhere.intval = 1
    andWhere.wrap = uid=|
    #orderBy = name ASC
    pidInList = 3
    }

    wrap = <div class="membersDetail">|</div>

    renderObj = FLUIDTEMPLATE
    renderObj {

    file = {$cc.tmpl.detail}

    variables{

    portrait = FILES
    portrait{
    references {
    table = tt_address
    uid.field = uid
    fieldName = image
    }
    begin = 0
    maxItems = 1
    renderObj = IMAGE
    renderObj {
    file {
    width = 130
    #height = 250c
    import.data = file:current:publicUrl
    treatIdAsReference = 1
    }
    }
    }

    uid = TEXT
    uid.field = uid

    name = TEXT
    name {
    field = name
    }

    }
    }

    renderObj.stdWrap.append = TEXT
    renderObj.stdWrap.append{
    value = Zurück
    typolink.parameter.data = page:uid
    }
    }

    stdWrap.override.if {
    isTrue.data = GP:ts_addresslist|showUid
    isTrue.intval = 1
    }

    }

    [/code]

    Nun zu meinem Problem: Ich sehe in der Übersicht die Ausgabe aller Einträge. Alles bis dahin kein Problem. Auch die Detailansicht klappt :) nun kommt das ABER: Leider klappt das nicht bei allen Einträgen .. zB. Einträge die mit einem Z(Name= Z...) beginnen oder Einträge die zB. ein ".net" oder ".org" enthalten werden einfach in der Detailansicht nicht angezeigt. Sehr komisch. Ich weiß leider nicht mehr weiter!

    Ansonsten läuft hier auf einem Linux ein Typo3 7.6.


  • 1
  • 1