[Frage] "Error: no file object" bei Ausgabe der Seitenressourcen TYPO3-Version: 7.6.16

  • Snoopie Snoopie
    TYPO3-Anwärter
    0 x
    7 Beiträge
    0 Hilfreiche Beiträge
    12. 06. 2017, 11:45

    Hallo,

    ich habe im Kopfbereich der Websites Header-Bilder, die ich unter Seiteneigenschaften und Ressourcen zur Verfügung stelle. Wegen der Sichtbarkeit bei SEO habe ich bei der Website die alt- und title-Attribute der Headerbilder entsprechend gepflegt.
    Ich versuche die Inhalte der IMG-Attribute "alt" und "title" in den Source-Code zu bekommen.

    1. lib.headerimage = IMAGE
    2. lib.headerimage {
    3. file {
    4. import.data = levelmedia:-1, slide
    5. treatIdAsReference = 1
    6. #import.listNum = 0
    7. import.listNum = rand
    8. parameter = 1
    9. }
    10. }
    11. altText.data = file:current:alternative
    12. titleText.data = file:current:title
    13. }

    1. <f:cObject typoscriptObjectPath="lib.headerimage" data="{uid:'{page.uid}'}" />

    1. <img src="https://www.websites.com/fileadmin/user_upload/Images/Header-Logo_02.png" width="8314" height="1521" alt="Error: no file object" title="Error: no file object" border="0">

    Wie lässt sich dieser Fehler beheben? Mit der Methode, die ich bis 6.2.9 noch eingesetzt hatte

    1. lib.headerimage = IMAGE
    2. lib.headerimage {
    3. file {
    4. import.data = levelmedia:-1, slide
    5. treatIdAsReference = 1
    6. #import.listNum = 0
    7. import.listNum = rand
    8. parameter = 1
    9. }
    10. }
    11. }

    bleiben die beiden Attribute jedoch komplett leer.

    Vielen Dank

    Snoopy


  • 1
  • 1