[Frage] Upgrade von 6.2.x auf 8.7.1 TYPO3-Version: 8.7.1

  • morange morange
    T3PO
    0 x
    21 Beiträge
    0 Hilfreiche Beiträge
    15. 05. 2017, 13:14

    Hallo allerseits,

    der Fileadmin in der aktualisierten TYPO3 8.7.1 ist nicht erreichbar. Als Fehlermeldung erscheint hier
    Uncaught TYPO3 Exception
    #1325689164: Parent folder "/" does not exist. (More information)

    InvalidArgumentException thrown in file
    /Users/steffenmatthes/Sites/_typo3/_95sjr-aktualisierung/typo3_src-8.7.1/typo3/sysext/core/Classes/Resource/ResourceStorage.php in line 2276.
    21 TYPO3\CMS\Core\Resource\ResourceStorage::createFolder("_processed_", TYPO3\CMS\Core\Resource\Folder)

    /Users/steffenmatthes/Sites/_typo3/_95sjr-aktualisierung/typo3_src-8.7.1/typo3/sysext/core/Classes/Resource/ResourceStorage.php:

    02864: $currentEvaluatePermissions = $this->evaluatePermissions;
    02865: $this->evaluatePermissions = false;

    02866: $this->processingFolder = $this->createFolder(

    02867: $processingFolder,
    02868: $rootFolder

    Scheinbar versucht das System den "_processed_" Ordner anzulegen – der ist aber vorhanden.

    Kann mir jemand sagen, wie ich den Fehler beheben kann?
    VG M.Orange


  • 1
  • Norman2k Norman2k
    Jedi-General
    0 x
    1595 Beiträge
    68 Hilfreiche Beiträge
    15. 05. 2017, 15:45

    Upgrade-Wizard ohne Probleme durch gelaufen? Hast du das Upgrade von 6.2 direkt auf 8.7 gemacht oder mit Zwischenschritt über 7.6? Irgendwelche Fehlermeldungen im Install Tool?

  • morange morange
    T3PO
    0 x
    21 Beiträge
    0 Hilfreiche Beiträge
    15. 05. 2017, 16:30

    Hi Norman2k,

    upps, nee der wirft n ordentlichen Fehler.

    An exception occurred while executing 'SELECT COUNT(*) FROM `sys_refindex` WHERE `hash` <> LOWER(MD5(CONCAT_WS('///', CAST(`tablename` AS CHAR), CAST(`recuid` AS CHAR), CAST(`field` AS CHAR), CAST(`flexpointer` AS CHAR), CAST(`softref_key` AS CHAR), CAST(`softref_id` AS CHAR), CAST(`deleted` AS CHAR), CAST(`workspace` AS CHAR), CAST(`ref_table` AS CHAR), CAST(`ref_uid` AS CHAR), CAST(`ref_string` AS CHAR), '2')))': Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '<>'

    Doctrine\DBAL\Exception\DriverException thrown in file
    /typo3_src-8.7.1/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php in line 115.

    Die Upgrades habe ich stufenweise gemacht, das von der 7.6 auf die 8.7 war allerdings recht hacklig. Da waren bei einigen Versuchen die Inhalte nicht mehr sichtbar.

    Vor den Upgrades waren die Tabellen-Kollationen sehr durch einander (utf8_general_ci, latin1_swedish_ci, latin1_german2_ci) – sprich diese Unsauberkeiten in der alten Installation kann ich nicht bereinigen? SOllte ich das tun oder die Tabellen in Ruhe lassen?

    Besten Dank
    M.Orange

  • Norman2k Norman2k
    Jedi-General
    0 x
    1595 Beiträge
    68 Hilfreiche Beiträge
    15. 05. 2017, 17:34

    Da musst du auf jeden Fall bei, siehst ja auch an der Fehlermeldung

    Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '<>'

    Wundert mich ein bisschen, dass dieser Mix aus unterschiedlichen collations überhaupt mit 6.2 vernünftig lief. Ich würde das alles direkt in der 6.2er Version bereinigen und dann erst upgraden.

  • morange morange
    T3PO
    0 x
    21 Beiträge
    0 Hilfreiche Beiträge
    15. 05. 2017, 17:39

    okay, danke dir für die info. (Y)

  • morange morange
    T3PO
    0 x
    21 Beiträge
    0 Hilfreiche Beiträge
    18. 05. 2017, 16:11

    Hi Norman2K,

    also ich hab die Upgrades inzwischen alle schrittweise wiederholt, allerdings mit dem gleichen Ergbins. :(

    Vorgegangen bin ich wie folgt:

    • Typo3 & alle Extensions auf die aktuellen gebacht
    • Kollationen alle auf utf8_general_ci gestetzt
    • Upgrade auf 7.6.x
    • alle Extension geupdatet
    • Fehlerfreie Installation
    • Upgrade auf 8.7.x

    In der 8.7er Version funzt dann plötzlich der Upgrade Wizard und die Filelist plötzlich nicht mehr.

    ###########################
    Fehlermeldung Upgrade Wizard:
    ###########################
    An exception occurred while executing 'SELECT COUNT(*) FROM `sys_refindex` WHERE `hash` <> LOWER(MD5(CONCAT_WS('///', CAST(`tablename` AS CHAR), CAST(`recuid` AS CHAR), CAST(`field` AS CHAR), CAST(`flexpointer` AS CHAR), CAST(`softref_key` AS CHAR), CAST(`softref_id` AS CHAR), CAST(`deleted` AS CHAR), CAST(`workspace` AS CHAR), CAST(`ref_table` AS CHAR), CAST(`ref_uid` AS CHAR), CAST(`ref_string` AS CHAR), '2')))': Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '<>'

    Doctrine\DBAL\Exception\DriverException thrown in file
    /PROJEKT/typo3_src-8.7.1/vendor/doctrine/dbal/lib/Doctrine/DBAL/Driver/AbstractMySQLDriver.php in line 115.

    ###########################
    Fehlermeldung Filelist:
    ###########################
    #1325689164: Parent folder "/" does not exist. (More information)

    InvalidArgumentException thrown in file
    /PROJEKT/typo3_src-8.7.1/typo3/sysext/core/Classes/Resource/ResourceStorage.php in line 2276.

    Wenn hier jemand ne Idee hat, wie ich das gefixt bekomme - immer gerne …

    Besten Dank für Eure Hilfe
    M.Orange

  • mchenzi mchenzi
    Jedi-Meister
    0 x
    317 Beiträge
    0 Hilfreiche Beiträge
    02. 06. 2017, 16:55

    Habe das gleiche Problem. Schon gelöst?

  • seebold seebold
    T3PO
    0 x
    29 Beiträge
    1 Hilfreiche Beiträge
    04. 10. 2017, 14:53

    Und auch mich würde das interessieren :-)
    Teile Dich uns mit.

    Grüße
    Martin

  • BastianBalthasarBux BastianBa...
    Jedi-Ratsmitglied
    0 x
    749 Beiträge
    7 Hilfreiche Beiträge
    20. 10. 2017, 13:58

    "Illegal mix of collations" ->
    das deutet auf Probleme mit der Datenbank oder der Datenbank Connection hin.
    nach folgendem Satz:
    "Kollationen alle auf utf8_general_ci gestetzt"
    denke ich, es wurden zwar alle collations richtig gesetzt, es wurde aber vergessen, dass man auch den INHALT der datenbank konvertieren muss, wenn man von latin_swedish (!!) nach utf8 will.

    Habe selbst bereits mehrfach von 7.6.x nach 8.7.x migriert. Da ich aber die Umstellung auf komplettes, echtes utf-8 bereits irgendwann bei Version 4.3/4.4/4.5 durchgeführt habe, für alle Bestandskunden, also vor ~ 10 Jahren, hatte ich eben jetzt noch nie Probleme.
    Ich kann mich allerdings erinnern, dass die Migration nach UTF-8 eher sehr mühsam war.
    Es gibt hier einige Threads zu dem Thema, auch mit Kommentaren von mir, die Forensuche hilft vielleicht.

    To err is human; to really screw things up requires the root password.
    https://www.Riccabona.IT/
    https://T3BOARD18.TYPO3.org/

  • 1