[Frage] Update von 6.2 auf 7.6 - CE's können nicht mehr erstellt werden TYPO3-Version: 7.6.9

  • mimii mimii
    Jedi-Ratsmitglied
    0 x
    578 Beiträge
    1 Hilfreiche Beiträge
    09. 05. 2017, 11:05

    Hallo ins Forum,

    dumm gelaufen.... es wurde ein Update von 6.2 auf 7.6 gemacht ohne vorher Extensions zu prüfen und ggf. zu aktualisieren. Man kann sich noch ins BE einloggen, die Seitenstruktur und die CEs sind da, FE läuft auch noch. ABER es können im BE keine CEs mehr gespeichert werden. Es erscheint folgender Fehler:Fatal error: Class 'TYPO3\CMS\Backend\Form\FormEngine' not found in /html/typo3/typo3_src-7.6.18/typo3/sysext/core/Classes/Utility/GeneralUtility.php on line 4535

    Die bisherigen CEs sind mit css_styled_content angelegt. Das soll auch, wenn möglich erst mal so bleiben, sonst müssten alle Templates umgestellt werden. css_styled_content ist auch nach wie vor bei bei den static includes eingetragen.

    Als Erweiterungen sind lediglich realurl(1.13.3) und gridelements(3.2.0) zusätzlich installiert.

    Da hat es doch irgendwas total zerhauen, oder? Wie krieg ich das nun wieder auf einen sauberen, funktionsfähigen Stand? Immer nett, wenn man die Fehler von anderen ausbügeln darf ;-)

    Danke für Eure Tipps

    Gruß
    mimii


  • 1
  • Teisinger Teisinger
    Jedi-Meister
    0 x
    364 Beiträge
    25 Hilfreiche Beiträge
    10. 05. 2017, 20:04

    erst einmal ins install-tool und gucken was die DB sagt - bzw. diese prüfen lassen. Alle nicht core extensions mal deaktivieren - die DB einträge der extensions müssen aber vorhanden bleiben, sonst ist der content auch weg!

    gibts ne fehlermeldung beim speichern? was sagen die logs?

    https://github.com/groundstack-org

  • Norman2k Norman2k
    Jedi-General
    0 x
    1650 Beiträge
    76 Hilfreiche Beiträge
    12. 05. 2017, 08:55

    Das was Teisinger sagt, der Fehler dürft durch die alte Version von Gridelements verursacht werden

  • 1