[Frage] Eigene Extension mit typo3 V7.x kompatibel machen

  • HH HH
    Jedi-Meister
    0 x
    347 Beiträge
    0 Hilfreiche Beiträge
    05. 05. 2017, 18:55

    Hallo,
    ich habe eine Extension damals mit einer typo3 v4.x aber bereits mit dem Extensionnbuilder entwickelt.
    Diese Extension ist leider nicht mehr mit der Version 7.x kompatibel.
    Was kann ich da machen, bzw. was muss ich in der Extension ändern, dass die auch auf 7.x läuft?
    Ich würde die extension ungern neu entwickeln da in der Datenbank ca. 800 Datensätze gespeichert sind und verschiedene andere Extension auf diese Extension zurückgreifen....
    Viele Dank!!!
    HArald


  • 1
  • pstranghoener pstrangho...
    Die Macht
    0 x
    531 Beiträge
    24 Hilfreiche Beiträge
    08. 05. 2017, 10:21

    Hi Harald,

    ich schaue mir das gerne mal an und gebe dir dann Rückmeldung.
    Ein Tipp noch: Wenn du deine Beiträge mit Tags versiehst, ist es für die anderen User einfacher, deinen Beitrag zu finden und dir eventuell eine Antwort zu geben :)

    Beste Grüße
    Philipp

  • aemka aemka
    Jedi-Ratsmitglied
    0 x
    562 Beiträge
    9 Hilfreiche Beiträge
    17. 05. 2017, 09:26

    Was du grob machen must, ist Folgendes:
    - Alle Systemklassen wie Tx_Extbase_... und t3lib_... auf die neuen Namespace Namen umstellen
    - Dein TCA von tca.php und ext_tables.php nach Configuration/TCA/... verschieben
    - Einige Calls umbenennen und entfernen. Siehe Breaking Changes in 6 und 7.

    http://www.aemka.de/

  • 1