[Frage] Extension Builder für Typo3 8.x TYPO3-Version: 8.5.1

  • 0 x
    8 Beiträge
    0 Hilfreiche Beiträge
    06. 02. 2017, 11:12

    Hallo,

    ich entwickle seit vielen Jahren Extensions für Typo3. Zuerst mit dem Kickstarter und dann mit dem Extension Builder. Für Typo3 8.X steht dieser (zurzeit) ja noch nicht zur Verfügung. Da ich bei Google keine Alternativen finden kann, wollte ich mal in die Runde fragen womit Ihre eure Extensions "kickstartet"?
    Der Exetnsion Builder und vor allem das Domain Modelling Tool sind ja so großartig, dass ich ungern darauf verzichten will.

    [img]https://wiki.typo3.org/wiki/images/5/5a/Extension-builder-modeler.png[/img]


  • 1
  • toifel toifel
    Jedi-Ratsmitglied
    0 x
    831 Beiträge
    96 Hilfreiche Beiträge
    06. 02. 2017, 14:51

    Zum Kickstarter nutze ich aktuell immer noch den Extension Builder in einem Typo3 7.6.
    Die erstellten Extensions lassen sich in der Regel problemlos in 8.x installieren und dort weiter entwickeln.

  • 0 x
    8 Beiträge
    0 Hilfreiche Beiträge
    06. 02. 2017, 16:52

    Ja, so mache ich das auch. Aber ich stelle mir oft die Frage, ob es Alternativen gibt? Stutzig geworden bin ich heute als ich mir mal das Introduction Package angeschaut habe. Da wird der Extension Builder ja fast schon als Core Funktion angepriesen... Und die Screenshots haben mich schon vor Freud strahlen lassen. Aber das sind wohl nur hübsche Mock-ups... schau mal hier: http://philipp.wtf/35/
    [img]http://philipp.wtf/fileadmin/_processed_/csm_extensionbuilder_15092e6f7b.png[/img]

  • Coderbear Coderbear
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    28. 04. 2017, 13:07

    Leider gibt es aktuell Probleme bei der Erstellung von Extensions mit Typo3 8.7.
    Es ist etwas Nacharbeit nötig um valide Extensions zu erzeugen. Scheinbar gibt es neue Behandlungsroutinen in Fluid-StandaloneTemplates.

    Beispiel: In TCA-Files werden die Properties nicht "raw" gerendert, sondern mit "htmlspecialchars", also wie im Typo3 Standard. Gleiches Problem bei ext_tables.sql.
    Die Ursache befindet sich in den Code-Templates (extension_builder/Resources/Private/CodeTemplates/Extbase).
    Der Modeler funktioniert sonst noch recht gut.

  • Stafast Stafast
    T3PO
    0 x
    15 Beiträge
    0 Hilfreiche Beiträge
    19. 03. 2018, 20:23

    Auch wenn der Beitrag schon älter ist, möchte ich gerne die Lösung posten, weil das Listing bei Google ziemlich weit oben ist:

    Die aktuellste Version vom Builder findet man bei GitHub: https://github.com/FriendsOfTYPO3/extension_builder

  • 0 x
    18 Beiträge
    0 Hilfreiche Beiträge
    19. 03. 2018, 22:39

    ja,
    allerdings bin ich bei den mit dieser Version des Extension-Builders erzeugten Extensions auf ein anderes Problem gestoßen. Siehe meinene Frage von heute Nachmittag:
    https://www.typo3.net/forum/thematik/zeige/thema/126636/
    Ich weiß nicht, ob das am Builder liegt oder an etwas anderem.

  • 0 x
    16 Beiträge
    3 Hilfreiche Beiträge
    27. 08. 2018, 17:16

    Danke gidouille

  • 1