[Frage] Ergebnislinks der Indexsuche / indexed_search haben immer Sprachparameter zur Default Sprache TYPO3-Version: 7.6.11

  • Thorsten1508 Thorsten1...
    Padawan
    0 x
    47 Beiträge
    0 Hilfreiche Beiträge
    28. 11. 2016, 16:33

    Hallo zusammen,
    auch auf die Gefahr hin, dass es diese frage schon in einem anderen Forum gab, möchte ich trotzdem nochmal damit anfangen, da ich nirgends eine Klärung finden konnte.

    Also folgendes Problem:
    Ein TYPO3-System in Version 7.6.11 mit normaler Konfiguration. Nicht mehrsprachig!!! In den Ergebnissen der Indexsuche wird aber trotzdem der Sprachparameter ?L=0 an die Links der Ergebnisse angehängt. Hab schon Realurl deaktiviert und das mitgelieferte Template der Suche verwendet, aber ich krieg die Parameter einfach nicht weg.

    In der 6.2er Version hat das mit gleicher Konfiguration ohne Probleme geklappt.

    Kann mir da freundlicherweise jemand weiterhelfen oder zumindest einen Schubs in die richtige Richtung geben?

    Hier die (relevante) Config:

    1. config {
    2. uniqueLinkVars = 0
    3. doctype = html5
    4. simulateStaticDocuments = 0
    5. baseURL = {$baseurl}
    6. absRelPath = /
    7. tx_realurl_enable = 1
    8. prefixLocalAnchors = all
    9. sys_language_uid = 0
    10. locale_all = de_DE.utf8
    11. htmlTag_setParams = lang="de" dir="ltr"
    12. index_enable = 1
    13. index_metatags = 0
    14. }
    15.  
    16. ### Angaben fuer deutsche Sprache ###
    17. [globalVar = GP:L = 0]
    18. config.sys_language_uid = 0
    19. config.language = de
    20. config.locale_all = de_DE.utf8
    21. config.htmlTag_langKey = de-DE
    22. config.metaCharset = utf-8
    23. config.plugin.tx_indexedsearch._DEFAULT_PI_VARS.lang = 0
    24. [global]

    Hier mal noch der Link zu dem vermutlich selben Problem:
    [url]http://typo3-german.typo3.narkive.com/U0eJAncN/typo3-7-lts-indexed-search-l-parameter-in-den-suchergebnissen[/url]

    Vielen Dank


  • 1
  • 0 x
    25 Beiträge
    0 Hilfreiche Beiträge
    13. 06. 2018, 09:43

    Hallo Thorsten,

    hast du eine Lösung für das Problem gefunden?

    Beste Grüße

  • 1