[Frage] Indexed search liefert keine Ergebnisse über Suchfeld im Header TYPO3-Version: 7.6.9

  • xlarge74 xlarge74
    Padawan
    0 x
    40 Beiträge
    0 Hilfreiche Beiträge
    10. 09. 2016, 16:57

    Liebe Kollegen, bitte nicht böse sein, aber ich glaub ich seh den Wald vor lauter Bäumen nicht mehr.

    Ich habe mir ein Suchfeld mit Submit im Header gebastelt, das auf jeder Seite zu sehen ist.
    Wenn ich dort eine Suche starte, geht er auf die richtige Seite und übernimmt das gescuhte Wort in das Suchfeld der Such-Seite, führt die suche aber nciht durch.
    Wenn ich dann auf der Seite wo das Plugin liegt auf Suchen drücke, gibt er mir die Ergebnisse aus.

    Was übersehe ich?

    Hier mein Code vom Suchfeld:

    1. SEARCH = COA
    2. SEARCH {
    3. typolink.parameter = {$plugin.tx_indexedsearch.searchUID}
    4. typolink.returnLast = url
    5. wrap = <form class="searchfield" action="#" method="POST">|</form>
    6. wrap.splitChar = #
    7. }
    8. 10 = TEXT
    9. 10.value = <input id="searchfield_input" type="text" name="tx_indexedsearch_pi2[search][sword]" value=""/>
    10. 20 = TEXT
    11. 20.value = <input id="searchfield_submit" type="image" src="fileadmin/images/search.png" title="Suchen" name="tx_indexedsearch_pi2[search][submitButton]"/>
    12. }

    Besten Dank im vorhinein.

    lg
    Oliver


  • 1
  • 0 x
    3243 Beiträge
    151 Hilfreiche Beiträge
    12. 09. 2016, 09:14

    Hallo Oliver.

    Auch hier hat sich durch den Umbau auf Extbase bisschen was geändert, sodass alte Codeschnipsel nicht mehr funktionieren.
    Hintergrund ist groß, dass Extbase innerhalb der Formulare einige versteckte Felder mitführt, die u.a. die gültigen Parameternamen beinhalten, Prüf-Hashes usw.

    1. lib.searchBox = USER_INT
    2. lib.searchBox {
    3. userFunc = TYPO3\CMS\Extbase\Core\Bootstrap->run
    4. extensionName = IndexedSearch
    5. vendorName = TYPO3\CMS
    6. controller = Search
    7. pluginName = Pi2
    8. action = form
    9.  
    10. view =< plugin.tx_indexedsearch.view
    11. settings =< plugin.tx_indexedsearch.settings
    12. }
    https://forge.typo3.org/issues/66331

    Viele Grüße
    Julian

  • xlarge74 xlarge74
    Padawan
    0 x
    40 Beiträge
    0 Hilfreiche Beiträge
    12. 09. 2016, 09:56

    Lieber Julian,

    auch hier danke für deine Antwort, ich werde versuchen das Umzusetzen und melde mich wieder.

    lg
    Oliver

  • 1