[Frage] Vergrößerte Bilder werden extrem farbreduziert dargestellt

  • Kamasutra Kamasutra
    Sternenflotten-Admiral
    0 x
    169 Beiträge
    0 Hilfreiche Beiträge
    26. 07. 2016, 16:33

    Hallo ihr,

    es geht um die Bilder und ihre farblich korrekte Anzeige. Im fileadmin wurden Bilder, ganz normale jpg, hochgeladen. Wenn man sie sich dort anschaut, sehen sie passend aus. Wenn man im "Text und Bilder"-Baustein welche verknüpft, werden sie unter dem Reiter "Bilder" extrem farbreduziert angezeigt, meist mit einem Blau- bzw. Grün-Stich. Das dortige Info-Symbol öffnet ein Fenster, in dem das Bild jedoch wiederum korrekt dargestellt wird. Im Frontend betrachtet wird das eingefügte Bild völlig ordentlich angezeigt, bei Klick auf das Bild wird im nun aufgehenden Fenster das Bild zwar in größer jedoch wiederum extrem farbreduziert angezeigt. In der Spaltenanzeige mit der Übersicht der einzelnen Bausteinen sieht das Bild auch ordentlich aus.

    Via template habe ich nichts für Bilder definiert oder geändert. Es wurden keine Erweiterungen installiert. Weder über die html-Grundstruktur noch in der CSS-Datei wird in irgendeiner Weise etwas zu den Bildern geregelt. Es wurde "CSS Styled content" eingebunden, bei der Version 6.2.15.

    Beim Upload in den fileadmin-Ordner kann ich keine Einstellungen vornehmen. Im "Text und Bilder"-Baustein habe ich unter "Qualität und Typ" von jpg über png, gif und "Keine" bis hin zu "Standard" diverse Darstellungsarten ausprobiert: immer dasselbe Auftreten. Dort ist sonst nichts weiter definiert/geändert außer "Neben dem Text rechts" mit einer Spalte, was aber ja sowieso keinen Einfluss auf die farbliche Darstellung haben dürfte.

    Mein Problem ist, dass ich nicht mal weiß, wo ich überhaupt ansetzen muss mit Suchen, geschweige denn wie. Ist es ein Installationsproblem? Eins im fileadmin? In den grundlegenden Einstellungen? Im RTE? im TypoScript? ...? Und scheinbar fehlen mir auch die Ideen für passende Suchbegriffe, denn via Internet finde ich einfach keine vergleichbaren Fragen, deren Antworten mich ggfs. auf eine hilfreiche Fährte bringen könnten.

    Hat jemand eine Idee, wie ich das Problem beheben kann, und verrät sie mir? Oder wo ich mal genauer suchen sollte?

    Gruß in die Runde!


  • 1
  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    27. 07. 2016, 07:58

    Zitiert von: Kamasutra

    Mein Problem ist, dass ich nicht mal weiß, wo ich überhaupt ansetzen muss mit Suchen, geschweige denn wie.

    Ganz einfach: im linken Menü (Backend) gehst du auf System -> Installation,
    dort findest du dann den Punkt "Test Setup", wo du sämtliche Grafiktest durchführen kannst.
    Du findest dort teilweise auch Tips, welche Einstellungen bei Bildfehlern anzupassen sind.
    Das machst du wiederum unter "All Configuration" -> "$TYPO3_CONF_VARS['GFX']"

  • Kamasutra Kamasutra
    Sternenflotten-Admiral
    0 x
    169 Beiträge
    0 Hilfreiche Beiträge
    16. 03. 2017, 13:27

    Hallo Jenses,

    bitte entschuldige, dass ich gar nicht antwortete: Früher bekam ich immer eine Nachricht via E-Mail, dass jemand eine Antwort geschrieben hat; das ist diesmal nicht passiert und so dachte ich, dass eben niemand auf meine Frage reagiert hatte. Und da es eine private Seite ist, die mir zwar durchaus am Herzen liegt, für die aber generell nur wenig Zeit übrig bleibt, habe ich diesen Punkt erst einmal nicht weiter verfolgt.

    Vielen Dank aber auf jeden Fall für deine Antwort: ich habe es heute versucht und schlussendlich nach vielen anderen Problemen, die ich erst einmal lösen musste (Äh, wie komme ich denn jetzt in das Installationstool rein? Und wie speichere ich die Änderung ab? ...) mit Hilfe deiner Antwort plus ein paar Fundstücken im Netz hinbekommen. Einfach war's schlussendlich (wie erwartet...): [TYPO3_CONF_VARS][GFX][colorspace]= sRGB verträgt das s im RGB nicht. Und nachdem ich dann im Installations-Tool noch einmal alles habe "reinigen"lassen (Clean up => Clear processes files) werden die Bilder endlich so angezeigt, wie es sein soll. Yippeah!

  • 1