[Frage] [Frage] Fatal error nach Upgrade auf Typo3 v7 TYPO3-Version: -

  • 0 x
    64 Beiträge
    1 Hilfreiche Beiträge
    17. 07. 2016, 21:57

    Hallo,

    nachdem ich den Symlink auf den neuen Typo3 v7 Core gelegt habe, kommt beim aufruf von Domain.de/typo3 oder auch domain.de/typo3/install der folgende Fehler:

    Fatal error: Class 't3lib_error_ErrorHandler' not found in /yyy/test_v7/typo3_src-7.6.9/typo3/sysext/core/Classes/Utility/GeneralUtility.php on line 4536

    Das Verzeichnis Typo3_temp habe ich schon geleert, hat aber nichts gebracht.

    Schonmal danke für eure Hilfe!


  • 1
  • toifel toifel
    Jedi-Ratsmitglied
    0 x
    831 Beiträge
    96 Hilfreiche Beiträge
    18. 07. 2016, 13:24

    Der Cache liegt in typo3temp/. Falls du einen Ordner "Typo3_temp" im Webroot liegen hast, dann gehört dieser sehr wahrscheinlich nicht zur Typo3-Installation und du hast etwas anderes gelöscht, als die temporären Dateien von Typo3.

    Wenn dein Webserver mit OPcache o.Ä. läuft muss dieser auch geleert werden, dazu musst du den Webservice einmal neu starten.

  • 0 x
    64 Beiträge
    1 Hilfreiche Beiträge
    18. 07. 2016, 14:44

    Hallo toifel,

    das war mein fehler, es handelte sich schon um den typo3temp ordner.

    jedoch habe ich gerade den fehler gefunden. in meiner LocalConfiguration.php gab es zwei zeilen, welche den Fehler verursacht haben:

    'SYS' => 'debugExceptionHandler' => 't3lib_error_DebugExceptionHandler',
    und
    'SYS' => 'errorHandler' => 't3lib_error_ErrorHandler',

    nachdem ich die Zeilen gelöscht habe, ging alles. vermutlich handelt es sich noch um alte v4 elemente.

    gruß

  • 1