[Frage] Änderungen der locallang.xml werden ignoriert TYPO3-Version: 6.2.7

  • jofoet3 jofoet3
    T3PO
    0 x
    18 Beiträge
    0 Hilfreiche Beiträge
    16. 06. 2016, 14:40

    Ich habe hier ein System vor mir, welches an sich schon aus allen Nähten platzt, aber jetzt habe ich einen Bug beim 6.2er System vor mir, den es an sich nur bis zum 4.x gab.
    Wenn ich für Extensions die locallang.xml bearbeite, kommen die Änderungen nicht ins System.
    Ich habe schon viel probiert und nichts hat geholfen. beim 4er konnte man einfach eine cache-Tabelle leeren und der Fehler war weg, aber diese Tabelle gibts im 6.2 nicht mehr und wo der Cache für Extensions nun landet, kann ich nirgends ergründen.
    Anscheinend ist der alte Bug wieder da und nun nicht einmal mehr mit der alten Lösung behebbar. :(

    Hat jemand eine Idee, wie man das beheben könnte?
    Eine Extension habe ich im Code zurecht geflickt, aber das kann und will ich nicht ständig machen.


  • 1
  • jofoet3 jofoet3
    T3PO
    0 x
    18 Beiträge
    0 Hilfreiche Beiträge
    16. 06. 2016, 15:56

    Ok, habs gefunden, es war der System-Cache, welcher unter 6.2 ja nicht mehr so einfach erreichbar ist.
    So schaltet man sich den Menüpunkt wieder frei:
    In der UserTSconfig (nicht in der PageTSconfig!) folgendes eintragen:
    options.clearCache.system = 1

    Aber Achtung, wenn man schon, wie ich auch, arg herumprobiert und an der Extension herum geschraubt hat und diese Änderungen dadurch aktiv werden. Kann man sich fix mal einen Error 500 einhandeln, wenn da z.B. eine XML nicht mehr ganz standardkonform ist! ;)

  • 1