[Frage] "backend_layouts" und deren Verknüpfung mit mit der jeweiligen Frontend-Ausgabe (Typo 7.6.6) TYPO3-Version: -

  • k.wartin k.wartin
    T3PO
    0 x
    12 Beiträge
    0 Hilfreiche Beiträge
    28. 04. 2016, 16:43

    Hi alle zusammen,

    ich habe ein kleines Problem mit der Verwendung von Backend-Layouts bzw. der anschließenden Content-Ausgabe.

    [b]Was funktioniert:[/b]
    - ein backend_layout ist angelegt, wird auch korrekt im Backend verwendet
    - wenn ich auf einer Seite ein be_layout auswähle funktioniert auch die Anzeige im Frontend

    An diese Anleitung habe ich mich gehalten:
    [url]https://jweiland.net/video-anleitungen/typo3/typo3-projekte-verwalten/backend-layouts.html[/url]

    [b]Was funktioniert nicht?[/b]
    - kurz gesagt: scheinbar wird das Feld "backend_layout_next_level" nicht ausgewertet

    Folgenden Dummy habe ich mir gebaut:

    [code]temp.test = CASE
    temp.test {
    key.data = backend_layout
    key.ifEmpty.data = levelfield:-2, backend_layout_next_level, slide
    key.override.field = backend_layout

    1 = TEXT
    1.value = template-1

    default = TEXT
    default.value = template-default

    stdWrap.wrap = <div class="test">|</div>
    }
    [/code]

    Ich bekomme immer die Default-Ausgabe, nicht aber "template-1", welches an der root-page definiert wurde.

    In der LocalConfig.php habe ich "backend_layout_next_level" zu den RootLineFields hinzugefügt.

    Was zum Geier mache ich Falsch, bzw. habe ich vergessen?

    Vielen Dank schon einmal für Eure Hilfe.


  • 1
  • 1