20. 04. 2016, 09:56

Hallo,

ich habe eine Typo3-Seite von 4.4 auf 4.5 aktualisiert. Diese soll später noch auf die 6.2 bzw. 7 aktualisiert werden.

Zuvor hab ich aber ein kleines Problem. Und zwar wird auf der Seite MailformPlus Version 4.0.15 verwendet.
Da Diese Extension nicht mehr benutzt werden kann wöchte ich das Ganze auf formhandler migrieren.

Dazu habe ich Formhandler Version 1.7.1 installiert.

Jetzt habe ich eine Anleitung gefunden wie man das Typoscript bzw. das Template anpassen muss.
Aber jetzt mein Problem. Nach den Anpassungen erhalte ich nur die Meldung Es ist ein Fehler aufgetreten.

Das ts des Mailformplus ist über den Befehl:

  1. <INCLUDE_TYPOSCRIPT: source="FILE: fileadmin/cms/default/plugins/tx_thmailformplus.ts">

in der Datein includes.ts angegeben.
In dieser Datei wiederrum steht folgendes:
  1. plugin.tx_thmailformplus_pi1 {
  2. _CSS_DEFAULT_STYLE >
  3. }

Mehr nicht!

Dann gibt es noch die Template-Datei unter fileadmin/html/plugins/th_mailformplus.html
Diese ist auf der Seite unter dem Punkt Templatedatei auf der Seite Kontakt -> Plugin -> mailformplus eingebunden. (Siehe Bild kontakt.jpg)

Diese Datei hat folgenden Inhalt:
[code]<!-- ###TEMPLATE_FORM### begin -->
<form method="post" action="###REL_URL###">
<input type="hidden" name="id" value="###PID###" />
<input type="hidden" name="submitted" value="1" />
<input type="hidden" name="L" value="###value_L###" />
<input type="hidden" name="type" value="###value_type###" />
<fieldset>
<legend>Allgemeine Infos</legend>
<div class="type-text">
###error_f_name###
<label for="f_name">Name <sup title="Dies ist ein Pflichtfeld.">*</sup></label>
<input type="text" name="f_name" id="f_name" size="20" value="###value_f_name###" />
</div>
<div class="type-text">
###error_f_email###
<label for="f_email">E-Mail <sup title="Dies ist ein Pflichtfeld.">*</sup></label>
<input type="text" name="f_email" id="f_email" size="20" value="###value_f_email###" />
</div>
<div class="type-text">
###error_f_telefon###
<label for="f_telefon">Telefon <sup title="Dies ist ein Pflichtfeld.">*</sup></label>
<input type="text" name="f_telefon" id="f_telefon" size="20" value="###value_f_telefon###" />
</div>
<div class="type-text">
###error_f_nachricht###
<label for="f_nachricht">Nachricht <sup title="Dies ist ein Pflichtfeld.">*</sup></label>
<textarea name="f_nachricht" id="f_nachricht" cols="30" rows="7">###value_f_nachricht###</textarea>
</div>
</fieldset>
<div class="type-button">
<input type="submit" value="Absenden" id="submit" name="submit" />
</div>
</form>
<!-- ###TEMPLATE_FORM### end -->

<!-- ###TEMPLATE_EMAIL_RECEIVER### begin -->
Sehr geehrte Damen und Herren,
ein Besucher hat das Kontaktformular auf der Webseite ausgefüllt:

Name: ###f_name###
E-Mail: ###f_email###
Telefon: ###f_telefon###

Nachricht:
###f_nachricht###

<!-- ###TEMPLATE_EMAIL_RECEIVER### end -->[/code]

Ich habe laut dieser Anleitung[url]http://www.typo3-formhandler.com/blog/howtos/how-to-upgrade-from-th-mailformplus-to-formhandler/[/url] das Template angepasst und das ts hinzugefügt bzw. ersetzt.
Aber leider erhalte ich wie gesagt nur die Meldung "Es ist ein Fehler aufgetreten."

Könnt ihr mir bitte sagen was da noch falsch ist bzw. wie ich das hinbekomme?