[Frage] ws_flexslider Image Link TYPO3-Version: -

  • primeproductions primeprod...
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    31. 03. 2016, 11:21

    Hallo zusammen!

    Mein System:
    Typo3 7.6.4
    ws_flexslider
    Link zur Seite: http://www.brauchen.at/temp9/index.php?id=58
    Mein KnowHow: Anfänger

    Problem:
    Im Bottombereich ist der Slider eingefügt und soll als Untermenü funktionieren. Klickt man auf ein Bild so wird man auf eine Seite weiter geleitet.
    Im Backend sind unter Seite bei jedem Bild ein Link eingetragen. Die Bilder sind im Frontend jedoch nicht verlinkt, auch der Quellcode zeigt die Links nicht.

    Bereits versuchte Lösungswege:
    Ich habe Kontakt mit dem Entwickler der Extension aufgenommen welcher höfflich meinte ich soll in den Foren um Hilfe ersuchen. :(
    Auch habe ich versucht den von der Extension mitgelieferten ViewHelper in das Extensiontemplate (List.html) einzubinden: <f:synLink arguments="{link: slide.link}" /> Leider kein Erfolg oder ich habe es falsch gemacht!

    Nachdem ich nun schon einige Tage via Suchmaschinen und Foren recherchiere bin ich bis jetzt leider nicht weiter gekommen und bitte somit die Community recht herzlich um Hilfe!

    Besten Dank
    Mario

    @Admins: Sollte es schon einen Forumseintrag zu meiner Frage geben, habe ich diesen nicht gefunden und ich bitte daher einen Doppelpost zu entschuldigen!


  • 1
  • primeproductions primeprod...
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    04. 04. 2016, 14:02

    Hallo zusammen!

    Leider bin ich immer noch au der Suche nach einer Lösung! Es ist schön langsam zum durch drehen für mich! :(

    Ich bin auf meinen weiteren Recherchen darauf gestossen dass ich einen DynLinkViewHelper drum rum bauen soll in der Partial Datei des Sliders:

    1. <f:section name="Entry">
    2.  
    3. <li>
    4. <div class="slidercontent wsflexslider-{item.styleclass}">
    5. <f:if condition="{item.falImage}">
    6. <fs:DynLink arguments="{link: item.link}">
    7.  
    8. <f:image src="{item.falImage.uid}" treatIdAsReference="1" title="{item.falImage.originalResource.title}" alt="{item.falImage.originalResource.alternative}" width="{settings.maxwidth}" height="{settings.maxheight}" />
    9. </fs:DynLink>
    10.  
    11. </f:if>

    Hab dies auch getan! Leider ist das Problem damit nicht gelöst. ABER es wird zumindest im Frontend Quelltext schon mal etwas mehr angezeigt:

    1. <div class="slidercontent wsflexslider-style1">
    2.  
    3. <fs:DynLink arguments="{link: item.link}">
    4.  
    5. <img title="KOCH Türen - Innentüren aus Tirol - NATURA HELA G4" alt="KOCH Türen - Innentüren aus Tirol - NATURA HELA G4" src="fileadmin/user_upload/Tuerenserien/NATURA/thumbs/kochtueren_02-HELA_G4.png" width="95" height="183" />
    6. </fs:DynLink>
    7.  
    8.  
    9. <div class="caption-wrapper caption-align-left">
    10.  
    11. <div class="caption-text">
    12. <p class="caption-title"></p>
    13.  
    14. </div>
    15.  
    16. </div>
    17. </div>
    18. </li>

    Ich möchte euch hier nochmals bitten und aufrufen, seht euch meinen Post an und vielleicht kann mir wirklich einer von euch Profis weiterhelfen denn ich bin leider schon am verzweifeln!

    Danke euch!
    Lg. Mario

  • 1