[Frage] wec_map Fehlermeldung bei Tabellenkarte TYPO3-Version: 6.2.7

  • SteffenV SteffenV
    TYPO3-Anwärter
    0 x
    7 Beiträge
    0 Hilfreiche Beiträge
    17. 01. 2016, 17:11

    Wenn ich eine Tabellenkarte anlege, wird für jeden Eintrag der ausgewählten Tabelle (fe_users, tx_cal_location) einmal folgende Fehlermeldung ganz oben auf der Seite angezeigt:

    TYPO3\CMS\Core\Utility\GeneralUtility::callUserFunction

    |No class named WecMap|

    Wenn ich also 5 FE-User in der Tabelle habe, dann kommt die Meldung 5 mal.

    Typo3 Version ist 6.2.17 (ließ sich nicht auswählen)
    wec_map 3.1.1.
    alle anderen Extensions sind aktuell.

    Wer hat dazu eine Idee?

    Danke!

    Steffen


  • 1
  • maxhb maxhb
    Flash Gordon
    0 x
    2148 Beiträge
    0 Hilfreiche Beiträge
    12. 05. 2016, 10:21

    Stolpere gerade über den gleichen Fehler und bin bisher so weit, dass ich herausgefunden habe, dass der folgende Eintrag in der ext_localconf.php von cal den Fehler verursacht:

    1. $GLOBALS ['TYPO3_CONF_VARS'] ['EXTCONF'] ['tx_wecmap_pi3'] ['markerHook'] ['cal'] = 'TYPO3\\CMS\\Cal\\Hooks\\WecMap:&WecMap->getMarkerContent';

    Früher stand dort

    1. $GLOBALS ['TYPO3_CONF_VARS'] ['EXTCONF'] ['tx_wecmap_pi3'] ['markerHook'] ['cal'] = 'EXT:cal/hooks/class.tx_cal_wecmap.php:&tx_cal_wecmap->getMarkerContent';

    Die Zeile definiert welche Methode von dem hier dokumentierten Hook aufgerufen werden soll: https://docs.typo3.org/typo3cms/extensions/wec_map/Configuration/Hooks/WecTableMapMarkerHook/Index.html

    Sieht also so aus, als ob bei der Umstellung auf Namespaces etwas falsch gelaufen ist.

    LG
    maxhb

  • maxhb maxhb
    Flash Gordon
    0 x
    2148 Beiträge
    0 Hilfreiche Beiträge
    12. 05. 2016, 11:57

    Eigentlich ganz logisch, die Konfiguration muss folgendermaßen lauten:

    1. $GLOBALS ['TYPO3_CONF_VARS'] ['EXTCONF'] ['tx_wecmap_pi3'] ['markerHook'] ['cal'] = '&TYPO3\\CMS\\Cal\\Hooks\\WecMap->getMarkerContent';

    LG
    maxhb

  • 1