15. 10. 2015, 08:55

Hallo,

habe Gridelements 3.2.0 und TYPO3 6.2.15 im Einsatz. Dazu habe ich Gridelements für mehrere Spalten konfiguriert. Ich möchte jetzt jedoch noch ein Grid (Raster) in einem anderen Raster ablegen. Das verschachtelte Raster habe ich auf "topLevelLayout = 0" gesetzt, damit es auch dort eingefügt werden kann.

Jedoch bekomme ich dann stets die Fehlermeldung "Wert ist nicht erlaubt '-1'" (colPos) bei dem Raster, sobald es in einem anderen Raster ist.

Weiß jemand wieso das so ist oder ist es ein Bug in gridelements?

Hier meine TSconfig von den Grids...

  1. tx_gridelements.setup {
  2. full {
  3. title = Einspaltig
  4. description = Typischer Inhalt
  5. topLevelLayout = 1
  6.  
  7. frame = 2
  8.  
  9. config.colCount = 1
  10. config.rowCount = 1
  11. config.rows {
  12. 1 {
  13. columns {
  14. 1.name = Inhalt
  15. 1.colPos = 10
  16. }
  17. }
  18. }
  19. }
  20. }

  1. tx_gridelements.setup {
  2. accordion {
  3. title = Akkordeon
  4. description = Grundgerüst, hier werden die Akkordeon Elemente eingefügt
  5. topLevelLayout = 0
  6.  
  7. frame = 3
  8.  
  9. config.colCount = 1
  10. config.rowCount = 1
  11. config.rows {
  12. 1 {
  13. columns {
  14. 1.name = Akkordeon Elemente
  15. 1.colPos = 30
  16. #1.allowed = html,gridelements_pi1
  17. }
  18. }
  19. }
  20. }
  21. }

TypoScript kann alles, auch kochen! ...Man muss nur wissen wie ;-)

Take a look at my TYPO3 Extensions in the Repository:
content_designer, k23_imagecrop, nn_address and more...