06. 10. 2015, 10:01

Hallo zusammen,

[b]Vorwort:[/b]
in unserem Projekt habe ich mehrere Gridelements im Einsatz.
Für eines davon sind, trotz bekannter Nachteile, Flexforms im Einsatz.
Die Flexforms sind über das entsprechende Feld im Gridelement-Datensatz angegeben.
Alles funktioniert so, wie erwartet. Die Felder erscheinen, sind richtig konfiguriert, alles kein Problem.

[b]Problem:[/b]
Ziel ist es jedoch, ein Feld als exclude_field zu definieren, um es vor bestimmten Redakteuren zu verbergen. (Konkret: zus. HTML-Attribute als input-field, die im Notfall von der Agentur genutzt werden können um kurzfristig Styling-Wünsche zu realisieren, bis es zu einer stabilen Lösung kommt).

Das Feld ist wie folgt konfiguriert:

  1. <additionalAttributes>
  2. <TCEforms>
  3. <exclude>1</exclude>
  4. <label>Zusätzliche Attribute (class, ids, data-attributes etc.)</label>
  5. <config>
  6. <type>input</type>
  7. <size>30</size>
  8. <eval>trim</eval>
  9. </config>
  10. </TCEforms>
  11. </additionalAttributes>

[b]Frage:[/b]
Woran kann es liegen, dass das hier gezeigte Feld NICHT unter den Exclude-Fields im Backend erscheint?

[b]Umstände / Infos:[/b]
- Caches können ausgeschlossen werden, sind definitiv (selbst per CLI in entspr. Ordnern) gelöscht.
- TYPO3 Version 6.2.15
- Gridelements Version 3.2.0

Jemand einen Tipp? Wäre dankbar für jeden Lösungsansatz (vllt. gibt es auch Tipps unabhängig von Gridelements?)

Viele Grüße und Dank im Voraus

Julius Blatt // eifel-online GmbH
http://www.eifel-online.com