[Frage] Contentelement richtig auslesen TYPO3-Version: 6.2.7

  • bcmbcm bcmbcm
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    29. 09. 2015, 21:58

    Hallo,
    ich bin gerade dabei eine Art Onepager in Typo3 zu basteln, habe aber Probleme, mehrere Contentelemente in einer Sektion darzustellen.
    Generell habe ich mehrere Sektionen, von welchen jede mehrere Content Elemente enthalten kann. Das funktioniert auch ganz gut, außer es geht um Bilder, die werden nicht angezeigt, AUSSER ich binde sie in einem Textelement ein.
    Text & Images bzw Images Only zeigt die Überschrift an, nicht aber die Bilder selbst.
    Ich denke das Problem tritt auf, weil ich die Elemente in einen falschen Datentyp lade bzw über den falschen Parameter aufrufe.
    Hier der Code mit dem ich die Inhalte zusammenbaue:

    1. lib.sectionContent = HMENU
    2. lib.sectionContent {
    3. 1 = TMENU
    4. 1 {
    5. NO = 1
    6. NO {
    7. doNotLinkIt = 1
    8. //if.value = 4
    9. if.equals.field = doktype
    10. if.negate = 1
    11. 10 < temp.titleSectionId
    12. 10.wrap = <!!=|=>
    13. 20 = CONTENT
    14. 20 {
    15. table = tt_content
    16. pidInList.field = uid
    17. max=10
    18. }
    19. wrap = |</div>
    20. renderObj < tt_content
    21. renderObj = COA
    22. renderObj {
    23.  
    24. 10 = TEXT
    25. 10.field = header
    26. 10.wrap = <h1>|</h1>
    27.  
    28. //HIER VERMUTE ICH DEN FEHLER!!!
    29. 30 = TEXT
    30. 30.field = bodytext
    31. 30.wrap=<div style="width:100%; overflow:auto; padding: 10px;">|</div>
    32. }
    33. }
    34.  
    35. }
    36. }
    37. }
    38. }
    39. }

    Gibt es andere Datentypen, die ich dafür verwenden kann? Bzw wie komme ich ansonsten an den Seiteninhalt?

    Danke!


  • 1
  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    30. 09. 2015, 08:48

    Alles nach [b]renderObj =< tt_content[/b] raus, und dein Inhalt wird dir vernünftig angezeigt werden.
    Nur mit google&copy&paste und ohne Typoscript-Grundverständnis wird das nix werden,
    du verstehst ja nicht mal dein eigenes (?) Typoscript ;)

  • 1