[Frage] 301 Weiterleitung trotz korrektem realurl_conf-Eintrag TYPO3-Version: 6.2.7

  • intensivstation intensivs...
    Sternenflotten-Admiral
    0 x
    200 Beiträge
    0 Hilfreiche Beiträge
    15. 09. 2015, 11:02

    Ziel ist es, eine sitemap.xml-Seite zu bauen, ohne dass eine 301-Weiterleitung zu ner anderen Seite weiterleitet. Das geht es theoretisch mit realURL wunderbar so:

    1. ...
    2. 'fileName' => array (
    3. 'defaultToHTMLsuffixOnPrev' => 0,
    4. 'index' => array (
    5. 'sitemap.xml' => array(
    6. 'keyValues' => array(
    7. 'type' => 841132,
    8. ),
    9. ),
    10. ),
    11. ),
    12. ...

    Trotzdem läuft das nur bei einem Projekt korrekt.
    Bei einem anderen wird trotzdem eine 301-Weiterleitung auf die Seite
    index.php?id=home&type=841132
    gemacht. Das ist unerwünscht. Woran kann das liegen?

    Tags: RealUrl

  • 1
  • jp_dev jp_dev
    T3PO
    0 x
    28 Beiträge
    0 Hilfreiche Beiträge
    18. 09. 2015, 13:13

    Ist die Startseite/root-Page evtl. einmal eine Weiterleitung und einmal nicht?
    Das verursacht bei bestimmten XML-Sitemap-Extensions immer probleme.

  • intensivstation intensivs...
    Sternenflotten-Admiral
    0 x
    200 Beiträge
    0 Hilfreiche Beiträge
    21. 09. 2015, 11:01

    In der Tat. So ist es. Daran könnte es legen.
    Es ist übrigens die metaseo-Extension im Einsatz, die ähnlich wie tq_seo ist.
    Gibt es auch einen Lösungsvorschlag?

  • intensivstation intensivs...
    Sternenflotten-Admiral
    0 x
    200 Beiträge
    0 Hilfreiche Beiträge
    21. 09. 2015, 11:28

    OK, die Vermutung konnte ich jetzt sogar bestätigen.
    Gleiches Problem aber auch mit den RSS-Feeds, die mit metaseo gar nichts zu tun haben...

  • 1