[Frage] Bild aus fileadmin eingebunden - > Größe stimmt nicht TYPO3-Version: 6.2.7

  • mimii mimii
    Jedi-Ratsmitglied
    0 x
    600 Beiträge
    1 Hilfreiche Beiträge
    15. 07. 2015, 12:57

    Hallo ins Forum,

    ich hole mir ein Logo (200x49 Pixel) aus fileadmin. Hierzu habe ich in den Konstanten das stehen

    1. logo.file = fileadmin/Resources/Public/Img/logo.png
    2. logo.text = Mein Logo
    3. logo.title = Mein Logo

    und im TS das
    1. lib.header_logo = IMAGE
    2. lib.header_logo {
    3. file = {$logo.file}
    4. stdWrap.typolink.parameter = 1
    5. params = class="logo"
    6. altText = {$logo.text}
    7. titleText = {$logo.title}
    8. altText.insertData = 1
    9. titleText.insertData = 1
    10. stdWrap.if.isTrue.data = TSFE:lastImageInfo|0
    11. }

    Das Logo wird angezeigt mit diesem HTML

    1. <a href="startseite.html"><img class="logo" width="400" border="0" height="96" title="Mein Logo" alt="Mein Logo" src="fileadmin/Resources/Public/Img/logo.png"></a>

    Problem ist, dass das die Originaldatei des Logos eigentlich [b]nur 200px breit und 49px hoch[/b] ist. Wie kommen die Angaben für width="400" und height="96" zustande?

    Im CSS steht für img lediglich

    1. img {
    2. border:none;
    3. max-width:100%;
    4. height:auto;}

    Danke für n Tipp und Gruß
    mimii


  • 1
  • toifel toifel
    Jedi-Ratsmitglied
    0 x
    831 Beiträge
    96 Hilfreiche Beiträge
    15. 07. 2015, 14:29

    Im Install-Tool gibt es die Option [GFX][im_noScaleUp].. wenn das aktiviert ist sollten die Bilder nicht mehr vergrößert werden.

  • mimii mimii
    Jedi-Ratsmitglied
    0 x
    600 Beiträge
    1 Hilfreiche Beiträge
    16. 07. 2015, 08:45

    Hallo,

    wäre ja zu einfach gewesen. Das Häckchen habe ich gesetzt, im Installtool dann noch alle Caches geleert. Das Bild bleibt zu groß, die width und height Angaben verändern sich nicht :-(

    Die Grafikinfo von Firefox zeight mir: [b]200px × 49px (Skaliert zu 400px × 98px)[/b]

    Gruß
    mimii

  • 1