[Frage] eigene Klasse für Bilder im RTE TYPO3-Version: 6.2.7

  • notknow notknow
    Jedi-Ritter
    0 x
    135 Beiträge
    2 Hilfreiche Beiträge
    02. 07. 2015, 13:17

    Hallo,

    ich stehe, auch nach Jahren, immer wieder wie ein Ochse vorm Berg bzgl. RTE.
    Alle Bilder im Content-Bereich haben einen border. Ich will eine Klasse im RTE, die einem Bild vergeben werden kann, um es ohne boder anzuzeigen:

    RTE.classes.img-no-border {
    name = Foto ohne Rahmen
    value = border-style: none;
    }

    RTE.default.classesImage = img-no-border
    RTE.proc.allowTagsOutside = img
    RTE.proc.allowedClasses := addToList(img-no-border)

    Im rte.css:
    img.img-no-border {border-style: none;}

    Das sollte es doch gewesen sein (sorry, Forum-Code-Ansicht bekomme ich nicht richtig angezeigt)?

    Ich sehe den Namen der Klasse im Pulldown, kann sie auswählen, aber sie bleibt nicht ausgewählt, verlasse ich mit der Maus das Pulldown steht dort wieder 'kein Textstil'. Ich kann die Einstellung also nichtmal speichern. Anleitungen von 2006 bis heute finden sich unendlich viele (immer weniger werdend - also scheint meine Aufgabenstellung recht basic und stabil zu sein).

    Was übersehe ich?

    EDIT:
    [b]Leuts, ich finde den Fehler nicht.[/b] Der Name der Klasse steht wie gewollt im Pulldown - ich fahre mit der Maus darüber - Klick - im Pulldown bleibt 'no text style / Kein Textstil' aktiv.

    Vielen Dank, liebe Grüße,
    Frank


  • 1
  • notknow notknow
    Jedi-Ritter
    0 x
    135 Beiträge
    2 Hilfreiche Beiträge
    06. 07. 2015, 10:48

    Im Quelltext des Backends sehe ich, dass meine eigene Bildklasse nach Auswahl im Pulldown sogar die richtige Klasse 'x-combo-selected' zugewiesen bekommt. Füe einen kurzen Moment.
    [b]Dann scheint ein JavaScript diese Klasse wieder zu entfernen noch während ich mich mit dem Mauszeiger über dem Pulldown befinde.[/b]
    Keine weiteren Anhaltspunkte bis jetzt. Ratlos...

    Ich habe 7 individuelle Klassen für Text, die alle funktionieren... Nur die eine fürs Bild nicht.

    Und testweise weitere Bildklassen angelegt, die alle im Pulldown erscheinen aber ebenso wenig auswähl/speicherbar sind wie die erste.

  • 1