[Frage] TYPO3 7.2.0 Installation: Backend nach Installation mit Internal Server Error/mod_fcgid error [Gelöst] TYPO3-Version: -

  • frankbi frankbi
    Padawan
    0 x
    57 Beiträge
    0 Hilfreiche Beiträge
    03. 06. 2015, 17:14

    Ich habe in einem Shared Hosting mit kleinen Leistungen versucht TYPO3 7.2 für eine eher anspruchslose Seite zum ersten Mal zu installieren (dachte mir neues Image Cropping/responsive BE wäre für Kunden besonders sinnvoll und neue LTS soll ja im Herbst kommen). Nach der Installation rufe ich das Backend auf und erhalte ohne Verzögerung einen 500/Internal Server Error.

    Frontend ("Oops ..." ) und Install Tool funktionieren. Neuinstallation bringt gleiches Ergebnis, auch bei Standard-Einstellungen im Install Tool. Datei-/Ordnerrechte auf 755/655 gesetzt wie vom Provider empfohlen.

    Zwei Fehlermeldung habe ich, Nr. 1 im Install Tool:
    "PCRE version too low Your PCRE version 7.8 2008-09-05 is too old. TYPO3 CMS may trigger PHP segmentantion faults with this version. Update to at least PCRE 8.30".
    Der Provider sagt, dies dürfte nicht relevant sein (PCRE-Update käme aber vorauss. mit Plesk-Update).

    Nr. 2 im error_log:
    "[warn][client ...] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [error][client ...] Premature end of script headers: index.php"
    Provider sagt, der Fehler sei zu allgemein.

    TYPO3 6.2.12 kann ich ohne Probleme und ohne Fehlermeldungen installieren.

    Liegt es an den erhöhten Systemanforderungen für die PHP environment von TYPO3 7?
    Ich habe hier widersprüchliche Angaben gefunden: [url]https://github.com/TYPO3/TYPO3.CMS/blob/master/INSTALL.md[/url] verlinkt von Download-Seite vs. [url]http://typo3.org/download/release-notes/whats-new/[/url], S. 5. Die Minimal-Bedingungen erfüllt der Tarif, die Angaben unter What's-new nicht.

  • snoofer snoofer
    TYPO3-Anwärter
    2 x
    2 Beiträge
    2 Hilfreiche Beiträge
    11. 06. 2015, 15:40 - Lösung

    Nur als Hinweis, weil ich auch über Google diesen Eintrag gefunden habe, es liegt an der pcre Version. Mit pcre < 8.1 funktioniert es nicht. Erst nachdem ich auf meinem 8.1 installiert hatte ging es wie gewünscht.
    Und die Warnmeldung beim Installieren von Typo3 gesagt es ja auch selbst :-)

    Ist natürlich bei einem Shared Hoster ein Problem. Aber immerhin weiß man warum es nicht geht.

  • Hilfreichster Beitrag

  • celmedia celmedia
    Padawan
    1 x
    49 Beiträge
    2 Hilfreiche Beiträge
    08. 06. 2015, 22:44 - Hilfreichster Beitrag

    hallo frankbi

    leider hab ich die lösung nicht wollte jedoch erwähnen das es bei mir genau so aussieht ...
    frontend "funktioniert"
    und das install tool geht auch über den link : domain.com/typo3/sysext/install/Start/Install.php
    jedoch im backen genau der selbe fehler wie bei dir...

    bist du schon weiter gekommen ???
    ... ich habe nun die version 7.0.0 installiert und das klappt soweit. bei 7.1.0 hab ich das selbe problem wieder und der hoster will da nicht viel unternehmen und verweist auf ältere versionen ...


  • 1
  • celmedia celmedia
    Padawan
    1 x
    49 Beiträge
    2 Hilfreiche Beiträge
    08. 06. 2015, 22:44

    hallo frankbi

    leider hab ich die lösung nicht wollte jedoch erwähnen das es bei mir genau so aussieht ...
    frontend "funktioniert"
    und das install tool geht auch über den link : domain.com/typo3/sysext/install/Start/Install.php
    jedoch im backen genau der selbe fehler wie bei dir...

    bist du schon weiter gekommen ???
    ... ich habe nun die version 7.0.0 installiert und das klappt soweit. bei 7.1.0 hab ich das selbe problem wieder und der hoster will da nicht viel unternehmen und verweist auf ältere versionen ...

  • frankbi frankbi
    Padawan
    0 x
    57 Beiträge
    0 Hilfreiche Beiträge
    08. 06. 2015, 22:51

    Danke für die Rückmeldung, celmedia! Tut mir leid, dass es bei Dir auch nicht klappt. Ich habe nichts Neues. Mein Provider will mich benachrichtigen, sobald TYPO3 7 unter Plesk als App/"One-Click" installierbar ist.

    Interessant, dass TYPO3 7.0 bei Dir geht. Das würde ich gern mal bei mir probieren ...

    Die gleichen/ähnliche Fehlermeldungen hast Du aber nicht, oder?
    Wie sind die Limits bei PHP (memory_limit, timeout etc.)?

    Ich kann mir weitere Basteleien und Verhandlungen (dürften auch wenig erfolgreich sein) in dem Projekt allerdings erstmal leider wohl nicht erlauben. Echt schade. Hätte TYPO3 7 gern ausprobiert.

  • celmedia celmedia
    Padawan
    0 x
    49 Beiträge
    2 Hilfreiche Beiträge
    09. 06. 2015, 00:25

    die nr 1 mit der PCRE Version hab ich auch und nr 2 das "Premature end of script headers: index.php" ebenfals ... hoffe jemand kann uns sagen an was das genau liegt ... laut dem hoster soll es nicht an der veralteten pcre liegen aber sie wiesen auch noch nicht genau weswegen ... wen jemand rat weis ist er natürlich herzlich wilkommen :-)

  • snoofer snoofer
    TYPO3-Anwärter
    2 x
    2 Beiträge
    2 Hilfreiche Beiträge
    11. 06. 2015, 15:40

    Nur als Hinweis, weil ich auch über Google diesen Eintrag gefunden habe, es liegt an der pcre Version. Mit pcre < 8.1 funktioniert es nicht. Erst nachdem ich auf meinem 8.1 installiert hatte ging es wie gewünscht.
    Und die Warnmeldung beim Installieren von Typo3 gesagt es ja auch selbst :-)

    Ist natürlich bei einem Shared Hoster ein Problem. Aber immerhin weiß man warum es nicht geht.

  • frankbi frankbi
    Padawan
    0 x
    57 Beiträge
    0 Hilfreiche Beiträge
    14. 06. 2015, 13:29

    Danke Euch beiden für die Rückmeldung! Sehr hilfreich, Snoofer! Ich habe meinem Provider nochmal geschrieben und bin gespannt.

  • frankbi frankbi
    Padawan
    0 x
    57 Beiträge
    0 Hilfreiche Beiträge
    22. 06. 2015, 10:28

    Ich kann jetzt PCRE 8.13 (2011-08-16) unter PHP 5.5.26 nutzen und das Backend funktioniert sofort (mittlerweile TYPO3 7.3). Also, keine Probleme mehr. Danke!

    Es erscheint bei der Installation und im Install-Tool zwar noch eine Fehlermeldung, s. u., aber es läuft bisher alles und dazu auffällig flott :) , auch wenn ich unter den Systemvoraussetzungen in der "What's new" bin. Keine entsprechenden Fehler mehr im error_log.

    Es gab bei meinem Provider kein Update von PCRE über Plesk, aber PCRE wurde manuell installiert.

    Die aktuelle Fehlermeldung:
    "PCRE version too low: Your PCRE version 8.13 2011-08-16 is too old.
    TYPO3 CMS may trigger PHP segmentantion faults with this version. Update
    to at least PCRE 8.30"

  • 1