[Frage] femanager, Email als Username und Editmode TYPO3-Version: 6.2.7

  • HH HH
    Jedi-Meister
    0 x
    347 Beiträge
    0 Hilfreiche Beiträge
    28. 02. 2015, 17:40

    Hallo,
    wenn ich beim femanager username.required = 0 setze, die email als Pflichtfeld, dann wird die Email als username verwendet. Das funktioniert soweit prima bei der Registrierung.

    Wenn ich ein Profil bearbeite, dann sollte der Nutzer die Möglichkeit haben die Email zu ändern.
    Damit sollte dann aber auch gleichzeitig der Nutzername geändert werden.
    Wie mach ich das am besten?

    Ist die einzige Möglichkeit, im Editmode, den Nutzername auszugeben, das Label des Nutzername auf Email zu setzen, die Validierung als email, und dann noch fillEmailWithUsername

    Oder gibts nen geschickteren weg?
    Danke!

  • Hilfreichster Beitrag

  • spL spL
    Jedi-Meister
    1 x
    345 Beiträge
    3 Hilfreiche Beiträge
    06. 04. 2017, 10:38 - Hilfreichster Beitrag

    Zitiert von: olek0707
    besteht bei euch das Problem immer noch?
    Ich habe eine Lösung gefunden.

    Sinnvoller Post ...

    Um die Frage (einigermaßen) abzuschließen:

    1. # Für EDIT und NEW reinnehmen
    2. fillEmailWithUsername = 1
    3.  
    4. email >
    5. username {
    6. uniqueInDb = 1
    7. email = 1
    8. }

    Bei dieser Lösung müsstest du in deinem Edit Template wohl das Feld E-Mail rausschmeißen und dafür das Feld Username dazunehmen. Falls gewünscht dann das Label von 'tx_femanager_domain_model_user.username' ändern in "E-Mail" statt "Benutzername".


  • 1
  • mchenzi mchenzi
    Jedi-Meister
    0 x
    317 Beiträge
    0 Hilfreiche Beiträge
    13. 05. 2015, 09:23

    Hallo
    Schon was rausgefunden. Ich habe das gleiche Problem

  • HH HH
    Jedi-Meister
    0 x
    347 Beiträge
    0 Hilfreiche Beiträge
    13. 05. 2015, 12:33

    nee, nichts gefunden

  • olek0707 olek0707
    Padawan
    0 x
    35 Beiträge
    0 Hilfreiche Beiträge
    29. 08. 2016, 16:38

    besteht bei euch das Problem immer noch?
    Ich habe eine Lösung gefunden.

  • Tosta Tosta
    R2-D2
    0 x
    114 Beiträge
    0 Hilfreiche Beiträge
    06. 09. 2016, 11:40

    Fein – und die wäre? Danke im Voraus!

  • spL spL
    Jedi-Meister
    1 x
    345 Beiträge
    3 Hilfreiche Beiträge
    06. 04. 2017, 10:38

    Zitiert von: olek0707
    besteht bei euch das Problem immer noch?
    Ich habe eine Lösung gefunden.

    Sinnvoller Post ...

    Um die Frage (einigermaßen) abzuschließen:

    1. # Für EDIT und NEW reinnehmen
    2. fillEmailWithUsername = 1
    3.  
    4. email >
    5. username {
    6. uniqueInDb = 1
    7. email = 1
    8. }

    Bei dieser Lösung müsstest du in deinem Edit Template wohl das Feld E-Mail rausschmeißen und dafür das Feld Username dazunehmen. Falls gewünscht dann das Label von 'tx_femanager_domain_model_user.username' ändern in "E-Mail" statt "Benutzername".

  • engler engler
    Padawan
    1 x
    58 Beiträge
    2 Hilfreiche Beiträge
    16. 10. 2017, 11:35

    noch einmal der Vollständigkeit halber: so klappt es bei mir:

    plugin.tx_femanager {
    settings {
    new {
    fillEmailWithUsername = 1
    validation {
    email >
    username {
    required = 1
    uniqueInDb = 1
    email = 1
    }
    }
    }

    }
    _LOCAL_LANG {
    # Field Labels
    default.tx_femanager_domain_model_user\.username = Email
    de.tx_femanager_domain_model_user\.username = E-Mail
    fr.tx_femanager_domain_model_user\.username = E-mail

    # Errormessages
    default.validationErrorRequired = This is a mandatory field
    de.validationErrorRequired = Hierbei handelt es sich um ein Pflichtfeld
    fr.validationErrorRequired = Ce champ est obligatoire
    }
    }

  • 1