[Frage] Fragen zur ersten eigenen extension TYPO3-Version: 6.2.7

  • hanssonny hanssonny
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    18. 12. 2014, 11:28

    Hallo Leute,

    ich hab einige fragen zu meiner ersten eigenen extension ...

    ich hab mit dem extension builder ein Modul angelegt ... ich hab 4 domänen angelegt und jetzt ist die default domäne die mit der action list augerufen wird immer die domäne B ich möchte aber dass beim aufruf der extension die domäne A aufgerufen wird ... wie kann ich das steuern?

    meine extension hat ein Backend Modul welches bei manchen servern angezeigt wird bei manchen nicht ...

    ich möcht eigentlich alle templates nur einmal ablegen und hab diese dazu unter Resources/Private/Backend abgelegt ....

    beim mir lokal geht das im xampp ... aufm webserver (ubuntu/apache) nicht.

    ich hab dann versucht die Configuration/TypoScript/constants.txt anzupassen und hier den pfad sowohl beim plugin als auch beim module auf
    Resources/Private/Backend/.. geändert ...

    das geht aber nicht aufm server wird immer angezeigt:

    Sorry, the requested view was not found.

    The technical reason is: No template was found. View could not be resolved for action "list" in class "ReRe\Rere\Controller\NoteController".


  • 1
  • toifel toifel
    Jedi-Ratsmitglied
    0 x
    831 Beiträge
    96 Hilfreiche Beiträge
    19. 12. 2014, 08:54

    Der Pfad ist unvollständig, sollte in den Constants bzw. im Setup in etwa so aussehen:
    EXT:Ordnername_deiner_extension/Resources/Private/Templates/Edit.html

    "Ordnername_deiner_extension" entsprechend ersetzen.
    Zusammen mit dem "EXT:" baut Typo3 den absoluten Pfad zu der Datei.

  • 1