[Frage] Bilder in der Kategorieliste anzeigen TYPO3-Version: 6.2.7

  • ralphle ralphle
    R2-D2
    0 x
    90 Beiträge
    0 Hilfreiche Beiträge
    14. 11. 2014, 13:43

    Hallo,
    Ich möchte in der tx_news-Kategorieliste (<f:section name="categoryTree">) das dazugehörige Kategoriebild anzeigen lassen. {category.item.title} und {category.item.description} etc.. geht ja wunderbar.
    Nur das Bild will mir nicht gelingen. Weiss jemand die genaue Syntax für das Fluidtemplate?

    {category.item.falMedia.0}
    {category.item.image}

    Alles schon probiert. Aber keine Ausgabe.
    Grüße Ralph


  • 1
  • dfluess dfluess
    Jedi-General
    0 x
    1293 Beiträge
    1 Hilfreiche Beiträge
    24. 11. 2014, 09:09

    Genau das würde mich auch interessieren. Gibts schon eine Lösung?

    Gruß Detlef

  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    24. 11. 2014, 09:23

    Macht doch einfach mal ein debug im Template:

    1. <f:debug title="category.item">{category.item} </f:debug>

    oder auch
    1. <f:debug title="category.item">{category.item.image} </f:debug>

    Und dann müßt ihr wohl einen image-Viewhelper einsetzen,
    category.item.image enthält sicher nur eine Referenz auf sys_files (? heißt die Tabelle so? )

  • dfluess dfluess
    Jedi-General
    0 x
    1293 Beiträge
    1 Hilfreiche Beiträge
    24. 11. 2014, 10:35

    Ja die Tabele sys_files, habe mit phpMyAdmin über die Tabellen gesucht.

    Das ganze ist für mich noch ziemlich verwirrend, da ich mich das erste mal mit fluid beschäftige.
    Debug wirft mir zwar nun Informationen aus, aber damit kann ich erstmal nicht viel anfangen.

    category.item.image
    ' ' (1 chars)

    Für category.item
    'Tx_News_Domain_Model_Category:3 ' (32 chars)

  • ralphle ralphle
    R2-D2
    0 x
    90 Beiträge
    0 Hilfreiche Beiträge
    24. 11. 2014, 12:52

    Hi,
    leider auch noch keine Erfolg gehabt:
    Hab das probiert:

    1. <f:debug title="category.item">{category.item.media}</f:debug>
    2. <f:debug title="category.item">{category.item.mediaPreviews.0}</f:debug>
    3. <f:debug title="category.item.mediaElement.image">{category.item.media.image}</f:debug>
    4. <f:debug title="category.item.mediaElement.image">{category.item.mediaPreviews}</f:debug>
    5. <f:debug title="category.item.mediaElement.image">{category.media}</f:debug>

    bringt keine Ausgabe (leer oder NULL). Die tx_news - Version für 6.1 hat wohl noch das Tabellenfeld "image" in Verwendung. Mittlerweile sollte ein 'media' oder 'falmedia' zum Einsatz kommen, oder? Fehlt für das Kategoriebild noch eine Klasse zum Abrufen des Bildes?

    Winkt noch jemand dem Zaunpfahl?

  • ralphle ralphle
    R2-D2
    0 x
    90 Beiträge
    0 Hilfreiche Beiträge
    15. 01. 2015, 11:28

    Nach langem Suchen - und es ist doch so einfach....

    1. <f:for each="{category.item.images}" as="image" >
    2. <f:image src="{image.uid}" alt="{image.title}" width='144' height="80" treatIdAsReference="1"/>
    3. </f:for >

    Wem es helfen mag....:)
    Grüße Ralph

  • 1