[Frage] Powermail 2.1 TYPO3-Version: -

  • Arnie2001 Arnie2001
    Jedi-Meister
    0 x
    317 Beiträge
    0 Hilfreiche Beiträge
    15. 10. 2014, 13:14

    Ich habe deine Erweiterung powermail von 2.0.16 auf die neueste Version gebracht, leider funktioniert nun folgendes nicht:

    lib.bikes = CONTENT
    lib.bikes {
    table = tt_news
    select {
    recursive = 1
    pidInList = 31
    andWhere {
    data = GP:newsid
    wrap = tt_news.uid=|
    }
    }
    renderObj = TEXT
    renderObj.field=title
    }

    plugin.tx_powermail{
    settings {
    setup {
    prefill {
    bike < lib.bikes
    }
    }
    }
    }

    Kann mir einer sagen warum, bzw. was ist nun anders?

    Mann muss nicht alles wissen, man sollte nur in Erfahrung bringen, wo es zu finden ist.


  • 1
  • einpraegsam.net einpraegs...
    MacGyver
    0 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    15. 10. 2014, 15:30

    Das sollte nach wie vor funktionieren.

    Ein kurzer Test ergab auch keinen Fehler:

    1. plugin.tx_powermail.settings.setup {
    2. prefill {
    3. # for field with marker {firstname}
    4. firstname = TEXT
    5. firstname.value = abcdefg
    6. }
    7. }

    Ein paar Ideen, wie man dem Problem auf die Spur kommen könnte:
    - Was ist, wenn du lib.bikes direkt auf (z.B.) page.1 ausgbist? Ist das korrekt?
    - Was ist, wenn du (ähnlich zu meinem Beispiel) einen statischen Wert vorbefüllen willst?
    - Heißt der Marker wirklich {bike}?

    Viele Grüße

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • 1