01. 10. 2014, 17:59

Hallo, ich habe ein altes Typo übernommen, erst mal müssen 2-3 Probleme gelöst werden:

Ich habe Mehrsprachigkeit hinzugefügt und möchte, dass wenn die Default-Sprache aufgerufen wird, also deutsch, dann auch kein /de/ in der URL steht. Dafür ist RealURL zuständig oder? Sorry, bin relativ neu in Typo und TS.

Dies ist mein Sprachenwechsler:

  1. temp.LELANGUAGESELECT = HMENU
  2. temp.LELANGUAGESELECT{
  3. special = language
  4. # Here we need to insert language ids in use
  5. special.value = 0,1
  6. # Set the default
  7. special.normalWhenNoLanguage = 0
  8. wrap = <ul> | </ul>
  9. 1 = TMENU
  10. 1 {
  11. wrap = <div><h1>Language</h1></div><ul>|</ul>
  12. NO = 1
  13. NO {
  14. linkWrap = <li class="first"> | </li> |*| <li> | </li> |*| <li class="last"> | </li>
  15. stdWrap.override = DE || EN
  16. ATagTitle = Deutsch || English
  17. doNotLinkIt = 1
  18. stdWrap.typolink.parameter.data = page:uid
  19. stdWrap.typolink.additionalParams = &L=0 || &L=1
  20. stdWrap.typolink.addQueryString = 1
  21. stdWrap.typolink.addQueryString.exclude = id,cHash,no_cache
  22. stdWrap.typolink.addQueryString.method = GET
  23. stdWrap.typolink.useCacheHash = 0
  24. stdWrap.typolink.no_cache = 0
  25. }
  26. ACT = 1
  27. ACT < .NO
  28. ACT.ATagParams = class = "active"
  29. ACT.doNotLinkIt = 1
  30. ACT.linkWrap = <li class="first active"> | </li> |*|<li class="active"> | </li> |*| <li class="last active"> | </li>
  31. }
  32. }

[b]Kann man das umsetzen?[/b]

[b]Wie kann ich nur die Sprachen anzeigen, die aktuell nicht ausgewählt sind?[/b] Also im Normalfall soll da nur "EN" stehen und auf /en/ weiterleiten, und ansonsten "DE" stehen und auf / weiterleiten. Es könnten auch noch mehr Sprachen hinzu kommen.

[b]Dann noch ein i-Tüpfelchen[/b]: Wenn eine Seite nicht übersetzt ist, dann sollten die Links auch nicht mit /en/ generiert werden auch wenn der Leser sich gerade auch auf einer englischen Seite befindet oder? Für die SEO wäre es doch schöner, wenn es die Seite unübersetzt nicht zwei mal gibt unter / und /en/? Vielleicht denk ich auch falsch und man macht das nicht so. Hinweise erwünscht!
Vielen Dank