[Frage] "powermail debug: show settings" im FE sichtbar TYPO3-Version: 6.1.7

  • hhheidi hhheidi
    T3PO
    0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    13. 08. 2014, 22:39

    liebes forum,

    nachdem ich nun meine lokal entwickelte seite online gestellt habe, taucht auf der seite mit dem kontaktformular über dem content ein riesiges fenster auf mit dem titel "powermail debug: show settings" und darin der ganze code der settings O.o

    in den konstanten von powermail habe ich diesbezüglich nichts gefunden was man da umstellen müsste/könnte...

    hat jemand eine idee?

    lieben dank!
    hh

    a-bit-of.me

  • Hilfreichster Beitrag

  • einpraegsam.net einpraegs...
    MacGyver
    1 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    13. 08. 2014, 23:22 - Hilfreichster Beitrag

    Hallo,

    powermail 2.0.x zeigt die Debugmeldungen, sofern per TypoScript aktiviert, im Frontend an.
    2 Möglichkeiten:
    1. Per TypoScript wieder ausschalten - trag mal plugin.tx_powermail.settings.setup.debug> ins Setup ein (über die Template Analyse solltest du auch herausfinden können, wo du die Einstellung gesetzt hast)
    2. Wenn du diesen Debug von Zeit zu Zeit brauchst, kannst du im Install Tool einstellen, dass diese Meldungen nur bei einer bestimmten IP-Adresse kommt

    BTW: in 2.1.x gibt es keine Frontend-Ausgabe mehr - hier wird devlog() genutzt

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/


  • 1
  • hhheidi hhheidi
    T3PO
    0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    13. 08. 2014, 23:14

    ... ich kann es auch nicht mit display: none ausblenden, da es im HTML code über dem headbereich steht ;( :

    1. <table class="typo3-debug" border="0" cellpadding="0" cellspacing="0" bgcolor="white" style="border:0px; margin-top:3px; margin-bottom:3px;">
    2. <tr>
    3. <td style="background-color:#bbbbbb; font-family: verdana,arial; font-weight: bold; font-size: 10px;">powermail debug: Show Settings</td>
    4. </tr>
    5.  
    6. ... hier der ganze settings code ...
    7. </td>
    8. </tr>
    9. </table>
    10. <!DOCTYPE html>
    11. <html lang="en" xmlns="http://www.w3.org/1999/xhtml">
    12.  
    13. <meta charset="utf-8">
    14. <!--
    15. This website is powered by TYPO3 - inspiring people to share!
    16.  
    17. ...

    a-bit-of.me

  • einpraegsam.net einpraegs...
    MacGyver
    1 x
    9340 Beiträge
    80 Hilfreiche Beiträge
    13. 08. 2014, 23:22

    Hallo,

    powermail 2.0.x zeigt die Debugmeldungen, sofern per TypoScript aktiviert, im Frontend an.
    2 Möglichkeiten:
    1. Per TypoScript wieder ausschalten - trag mal plugin.tx_powermail.settings.setup.debug> ins Setup ein (über die Template Analyse solltest du auch herausfinden können, wo du die Einstellung gesetzt hast)
    2. Wenn du diesen Debug von Zeit zu Zeit brauchst, kannst du im Install Tool einstellen, dass diese Meldungen nur bei einer bestimmten IP-Adresse kommt

    BTW: in 2.1.x gibt es keine Frontend-Ausgabe mehr - hier wird devlog() genutzt

    in2code.de - Wir leben TYPO3
    - Möchtest du TYPO3 komplett verstehen? Eigene Erweiterungen erstellen? Bei uns gibt es auch Schulungen https://www.in2code.de/produkte/typo3-schulungen/
    - Die Arbeit mit TYPO3 macht dir Spaß? Du stehst auf Berge? Komm zu uns! https://www.in2code.de/agentur/karriere/

  • hhheidi hhheidi
    T3PO
    0 x
    24 Beiträge
    0 Hilfreiche Beiträge
    14. 08. 2014, 01:53

    oh danke, danke, danke! prima, das hat funktioniert :)
    [nur das formular funktioniert jetzt nicht - weiter geht's mit try & error... -.- dazu aber wohl besser ein separater post...]

    a-bit-of.me

  • 1