[Frage] Autocomplete Fehler als Ausgabe TYPO3-Version: -

  • celmedia celmedia
    Padawan
    0 x
    49 Beiträge
    2 Hilfreiche Beiträge
    31. 07. 2014, 15:35

    Ich bin verzweifelt nach lösungen am googlen ... hab typo3 6.2.4 mit der suchfunktion die auch wunderbar funktioniert ... nun hab ich noch cb_indexedsearch_autocomplete installiert dieser klappt auch schön auf jedoch mit einem fehler .... (siehe bild )
    (undefined results)
    Fatal error: require_once(.... in der fe_index.php on line 25.

    nun hab ich schon etlich verweilt danach zu googlen und im forum rumgeschaut aber konnte nichts finden ... kann mir jemand hellfen ? hier ist ein ausschnitt der fe_index des modul ortners

    1. class tx_cb_indexedsearch_autocomplete_fe_index {
    2.  
    3. /*
    4. * Do the setup bit
    5. */
    6. function tx_cb_indexedsearch_autocomplete_fe_index() {
    7.  
    8. // include class def
    9. require_once(PATH_t3lib.'class.t3lib_page.php');
    10.  
    11. // Initialize FE user object:
    12. $this->feUserObj = tslib_eidtools::initFeUser();
    13.  
    14. // Connect to database:
    15. tslib_eidtools::connectDB();
    16.  
    17. $this->pages = array(intval(t3lib_div::_GET('sr')));
    18.  
    19. // hook for showing extension version
    20. if(intval(t3lib_div::_GET('sv')) > 0) {
    21. $_EXTKEY = "temp";
    22. require_once($GLOBALS['TYPO3_LOADED_EXT']['cb_indexedsearch_autocomplete']['siteRelPath'] . 'ext_emconf.php');
    23. die($EM_CONF[$_EXTKEY]['version']);
    24. }
    25.  
    26. // Setup enablefields def
    27. tslib_fe::includeTCA();
    28. $GLOBALS['TSFE']->gr_list = $this->feUserObj->user['usergroup'];
    29. $this->pageSelect = t3lib_div::makeInstance('t3lib_pageSelect');
    30. $this->enableFields = $this->pageSelect->enableFields('pages');
    31. // $this->enableFields = t3lib_pageSelect::enableFields('pages');
    32. $this->multipleGroupsWhereClause = $this->pageSelect->getMultipleGroupsWhereClause('gr_list', 'index_phash');
    33.  
    34. return true;
    35. }

    Anhänge (1)
    Bildschirmfoto am 2014-07-05 um 14.49.06.png image/png 0,00 B 341 heruntergeladen
  • Hilfreichster Beitrag

  • 1 x
    9 Beiträge
    1 Hilfreiche Beiträge
    17. 12. 2014, 16:43 - Hilfreichster Beitrag

    Auf Github hat einer die cb_indexedsearch_autocomplete mit 6.2 kompatibel gemacht, das kannst du dir z.B. als Git-Submodul einbinden: https://github.com/mgrundkoetter/cb_indexedsearch_autocomplete/tree/compat-6.2


  • 1
  • 1