[Frage] Plugin mit TS einbinden TYPO3-Version: -

  • 0 x
    10 Beiträge
    0 Hilfreiche Beiträge
    28. 07. 2014, 11:00

    Hallo zusammen,

    Ich kapier die Welt nicht mehr. Wieso funktioniert das nicht?

    1. lib.article = USER
    2. lib.article {
    3. userFunc = TYPO3\CMS\Extbase\Core\Bootstrap->run
    4. extensionName = Article
    5. pluginName = Articlelist
    6. vendorName = AQUA
    7. controller = Article
    8. action = list
    9.  
    10. settings =< plugin.tx_article.settings
    11. persistence =< plugin.tx_article.persistence
    12. view =< plugin.tx_article.view
    13. }

    ext_localconf.php

    1. \TYPO3\CMS\Extbase\Utility\ExtensionUtility::configurePlugin(
    2. 'AQUA.' . $_EXTKEY,
    3. 'Articlelist',
    4. 'Article' => 'list, show',
    5.  
    6. ),
    7. // non-cacheable actions
    8. 'Article' => '',
    9.  
    10. )
    11. );

    ext_tables.php

    1. \TYPO3\CMS\Extbase\Utility\ExtensionUtility::registerPlugin(
    2. $_EXTKEY,
    3. 'Articlelist',
    4. 'Article List'
    5. );

    1. <f:layout name="Default" />
    2. <f:section name="Main">
    3. <figure class="hero"></figure>
    4. <div class="row">
    5. <nav class="sub column small12">
    6. <f:cObject typoscriptObjectPath="menu.secondlevel" />
    7. </nav>
    8. </div>
    9. <section class="content">
    10. <div class="row">
    11. <div class="column small12">
    12. <h3>{data.title}</h3>
    13. </div>
    14. </div>
    15. <f:cObject typoscriptObjectPath="lib.article" />
    16. </section>
    17. </f:section>


  • 1
  • 0 x
    10 Beiträge
    0 Hilfreiche Beiträge
    28. 07. 2014, 11:53

    Funktioniert wunderbar lag an was anderem.. Habe im extention builder noch was am Vendor geändert, was dann ganz hartnäckig gecached wurde.

    Nun könnte der Aritkel als How to benutzt werden ;)

  • 1