[Frage] Einbindung Glyphicons

  • 0 x
    90 Beiträge
    0 Hilfreiche Beiträge
    26. 07. 2014, 20:34

    Hallo,

    in den Stylesheets von Bootstrap werden ja Glyphicons für grafische Zeichen einegbunden.

    @font-face {
    font-family: 'Glyphicons Halflings';
    src: url('../fonts/glyphicons-halflings-regular.eot');
    [...]
    }

    Parallel zu meinem css-Verzeichnis liegen nun also die gefragten Fonts.

    Im reinen HTML-Dummy funktioniert auch alles - erst, wenn ich die Inhalte über mein TYPO3 ausgebe, bekomme ich den Fehler in der Konsole:

    "NetworkError: 401 Authorization Required - http://[domain]/fileadmin/templates/fonts/glyphicons-halflings-regular.woff";
    glyphic...ar.woff
    Cross-Origin-Anfrage blockiert: Die Same-Origin-Regel verbietet, die externe Ressource auf http://[domain]/fileadmin/templates/fonts/glyphicons-halflings-regular.woff zu lesen.

    Domain ist aber absolut identisch.
    Ich glaube, wir haben das mal in einem Projekt gelöst, indem die fonts in die Root-Ebene kamen, aber das kann's nicht sein, da die font-face-Einbindung im Bootstrap-CSS ja irgendiwe funktionieren muss (schon um Update-fähig zu bleiben).

    Viele Grüße vom rhein,

    Stefan

    40236


  • 1
  • karlchen karlchen
    Jedi-General
    0 x
    1427 Beiträge
    30 Hilfreiche Beiträge
    28. 07. 2014, 10:47

    Hallo,

    ein "Authorization Required" kommt eigentlich immer wenn eine User/Password Abfrage benötgit wird um auf die Resource zuzugreifen. Sicher das dort nicht irgendwas schief läuft ? Habt ihr die Dateien schon mal normal im Browser aufgerufen ?

    Aber was spricht dagegen eine Bootstrap CSS Regel in deiner CSS zu überschreiben ? Auch würde ich bei einem laufenden Projekt keine Bootstrap CSS updaten, CSS ist für rein visuelle Punkte zuständig, es wird als keine Sicherheitsrelevanten Punkte berühren. Ein Update einer CSS scheint hier also eher unnötig, ihr könnte ja alle belange mit der eigenene CSS überschreiben.

  • 0 x
    90 Beiträge
    0 Hilfreiche Beiträge
    31. 07. 2014, 12:31

    Hallo,

    danke für den Tipp. Eventuell liegt es am htaccess-Schutz, manchmal funktioniert es aber und die Icons werden angezeigt... sehr merkwürdig.

    Ich kann die Font-Einbindung natürlich in meiner CSS überschreiben - aber solange die defekte dann noch in der Original-Bootstrap steht, gibt es weiterhin einen Error. Unschön, m.E. nicht so professionell - schöner wär, wenn der Aufruf klappt.

    Werde mal nach Freigabe (und Aufhebung des Passwortschutzes) schauen, ob das Problem noch mal auftaucht.

    40236

  • uandree uandree
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    21. 03. 2017, 10:01

    Dasselbe Problem habe ich momentan auch. Welche Lösung wurde letztendlich gefunden?

    Vielen Dank vorab.

  • 1