[Frage] Felder in Übersetzung verbieten [Gelöst] TYPO3-Version: 6.1.7

  • Chrissli Chrissli
    Jedi-General
    0 x
    1015 Beiträge
    28 Hilfreiche Beiträge
    25. 07. 2014, 13:44

    Hallo zusammen!

    Ich missbrauche das Abstract-Feld aus den Seiteneigenschaften als Konfiguratiosnfeld für einen zusätzlichen externen Datenbankzugriff, da dieses Feld bei mir eh nicht verwendet würde.
    Jetzt möchte ich jedoch, dass die Redakteure die die Übersetzungen eingeben und anlegen ger nicht erst auf die Idee kommen hier etwas einzutragen ( was ja eh ignoriert würde ).
    Gibt es eine einfache Möglichkeit dieses oder auch andere Felder für die Seitenübersetzungen zu verbergen?

    Danke im Voraus schon mal und ein schönes Wochenende euch allen!

    God's in his heaven, all's right with the world

  • karlchen karlchen
    Jedi-General
    2 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    28. 07. 2014, 11:06 - Lösung

    Hi, entweder im User TSConfig

    1. page.TCEFORM.pages_language_overlay.abstract.disabled = 1

    oder Seiten TSConfig

    1. TCEFORM.pages_language_overlay.abstract.disabled = 1

  • Hilfreichster Beitrag

  • Norman2k Norman2k
    Jedi-General
    1 x
    1650 Beiträge
    76 Hilfreiche Beiträge
    25. 07. 2014, 17:14 - Hilfreichster Beitrag

    Hey Chrissli

    Ich hätte jetzt auf sowas in die extTables.php getippt:
    $TCA['pages']['columns']['nav_title']['l10n_mode'] = 'exclude';
    $TCA['pages']['columns']['nav_title']['l10n_display'] = 'defaultAsReadonly';

    http://docs.typo3.org/typo3cms/TCAReference/Reference/Columns/Index.html#l10n-mode

    Allerdings hat das keine Auswirkung, selbst ein einfaches readOnly hat nur auf die deutsche Version Auswirkung
    $TCA['pages']['columns']['nav_title']['config']['readOnly'] = 1;

    Auch folgende Zeile ins Seiten-TSConfig blendet das Feld nur in der deutschen Version aus:
    TCEFORM.pages.nav_title.disabled = 1

    Jetzt will ich es aber auch wissen, seh ich grad den Wald vor lauter Bäumen nicht oder funktioniert das nicht so wie es soll?
    Ich hab es selber noch nie außerhalb einer Extension (wo es wie oben beschrieben in der tca.php funktioniert) benötigt, deshalb kann ich auch nicht sagen, ob das das Standard-Verhalten ist.
    Getestet mit 4.5 und 6.2, hab grad keine 6.1 hier


  • 1
  • Norman2k Norman2k
    Jedi-General
    1 x
    1650 Beiträge
    76 Hilfreiche Beiträge
    25. 07. 2014, 17:14

    Hey Chrissli

    Ich hätte jetzt auf sowas in die extTables.php getippt:
    $TCA['pages']['columns']['nav_title']['l10n_mode'] = 'exclude';
    $TCA['pages']['columns']['nav_title']['l10n_display'] = 'defaultAsReadonly';

    http://docs.typo3.org/typo3cms/TCAReference/Reference/Columns/Index.html#l10n-mode

    Allerdings hat das keine Auswirkung, selbst ein einfaches readOnly hat nur auf die deutsche Version Auswirkung
    $TCA['pages']['columns']['nav_title']['config']['readOnly'] = 1;

    Auch folgende Zeile ins Seiten-TSConfig blendet das Feld nur in der deutschen Version aus:
    TCEFORM.pages.nav_title.disabled = 1

    Jetzt will ich es aber auch wissen, seh ich grad den Wald vor lauter Bäumen nicht oder funktioniert das nicht so wie es soll?
    Ich hab es selber noch nie außerhalb einer Extension (wo es wie oben beschrieben in der tca.php funktioniert) benötigt, deshalb kann ich auch nicht sagen, ob das das Standard-Verhalten ist.
    Getestet mit 4.5 und 6.2, hab grad keine 6.1 hier

  • Chrissli Chrissli
    Jedi-General
    0 x
    1015 Beiträge
    28 Hilfreiche Beiträge
    28. 07. 2014, 10:53

    Danke für den Versuch, bei mir hat das leider nicht ansatzweise funktioniert #giggle#
    Aber dein Link hat mir dahingehen weitergeholfen, dass ich mittels

    1. $GLOBALS['TCA']['pages']['columns']['abstract']['exclude'] = 1;

    Das Feld generell ausblende und nur für bestimmte Benutzer aktiviere, das reicht in meinem Fall.
    Solltest du oder jemand anders hier noch etwas dazu heraus finden, immer her damit, aber mir persönlich würde das als Antwort reichen.

    Evtl. liegt es ja daran, dass die l10n-Einstellungen die du genannt hast nur dann funktionieren, wenn languageField in der ctrl-section gesetzt ist.
    Ist vielleicht falsch gedacht, aber vielleicht liegt das ja daran, dass pages das in diesem Sinne gar nicht hat, die Übersetzungen inkl. languageField liegen ja in pages_language_overlay.

    BTW: passt nicht unbedingt zum Thema, aber hat das einen speziellen Grund, dass mit tt_content und pages anders aufgebaut ist? Ich persönlich finde die Konstruktion mit pages und overlay bei eigenen SQL-Queries immer unnötig umständlich...

    God's in his heaven, all's right with the world

  • karlchen karlchen
    Jedi-General
    2 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    28. 07. 2014, 11:06

    Hi, entweder im User TSConfig

    1. page.TCEFORM.pages_language_overlay.abstract.disabled = 1

    oder Seiten TSConfig

    1. TCEFORM.pages_language_overlay.abstract.disabled = 1

  • Chrissli Chrissli
    Jedi-General
    0 x
    1015 Beiträge
    28 Hilfreiche Beiträge
    28. 07. 2014, 12:09

    Prima Danke, die Lösung find' ich fast noch schöner.

    @Norman2K: Musste dir leider aus Political Correctness die Lösung entziehen, den Daumen darfst aber natürlich behalten.

    Danke für euer aller Mühe

    God's in his heaven, all's right with the world

  • 1