[Frage] tt_address Problem [Gelöst] TYPO3-Version: 4.7.12

  • 0 x
    30 Beiträge
    0 Hilfreiche Beiträge
    07. 05. 2014, 12:45

    Hallo zusammen,

    bisher habe ich leider noch keine Lösung gefunden.

    Gerne würde ich den Wrap "<div class="tx-ttaddress-pi1"></div>" um das Content Element entfernen. Hat hier jemand einen Tipp?

    viele Grüsse

    aussteiger

  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    08. 05. 2014, 09:54 - Lösung

    Das wird höchstwahrscheinlich hartcodiert sein in der Main-Funktion der pi1-Klasse,
    etwa so:

    1. return $this->pi_wrapInBaseClass($content, $conf);

    Das müstest du ändern nach:
    1. return $content;

    Warum nun allerdings ein harmloses div als so störend empfunden wird,
    erschließt sich mir nicht ...


  • 1
  • jenses jenses
    Flash Gordon
    0 x
    3087 Beiträge
    106 Hilfreiche Beiträge
    08. 05. 2014, 09:54

    Das wird höchstwahrscheinlich hartcodiert sein in der Main-Funktion der pi1-Klasse,
    etwa so:

    1. return $this->pi_wrapInBaseClass($content, $conf);

    Das müstest du ändern nach:
    1. return $content;

    Warum nun allerdings ein harmloses div als so störend empfunden wird,
    erschließt sich mir nicht ...

  • 0 x
    30 Beiträge
    0 Hilfreiche Beiträge
    08. 05. 2014, 10:22

    Vielen Dank für den Hinweis.

    Der Wrap war in der Zeile:

    1. return $this->pi_wrapInBaseClass($content);

    Ja leider muss ich diesen div entfernen. Es ist für eine spezielle Anzeige nötig.

  • 1