[Frage] FAL-Datensätze werden nicht übersetzt

  • Tom-iX Tom-iX
    Sternenflotten-Admiral
    0 x
    174 Beiträge
    0 Hilfreiche Beiträge
    02. 04. 2014, 10:22

    Hallo zusammen,

    bin zur Zeit bei der Entwicklung einer Extension, hier gibt es Produkte, Anwendungen, Medien-Dateien.
    Produkt -> Anwendungen -> Medien-Dateien

    Ich weiß gerade nicht mehr wo ich den Fehler suchen soll.

    Wenn ich ein Produkt aufrufe, werden die zugeordneten und übersetzten Anwendungs-Datensätze richtig übersetzt, die Medien-Dateien (über FAL) welche in den Anwendungen zugeordnet sind werden leider nicht übersetzt.
    D.h. Eine Anwendung hat in den jeweiligen Sprachen verschieden Medien-Dateien welche zugeordnet werden können.

    Ich verwendet TYPO3 V6.1.7

    Vielen Dank für die Mithilfe oder Tipps.
    Thomas

    base iX. individual websolutions | http://www.base-ix.de


  • 1
  • aemka aemka
    Jedi-Ratsmitglied
    0 x
    562 Beiträge
    9 Hilfreiche Beiträge
    07. 04. 2014, 12:26

    Richtige Mehrsprachigkeit für FAL vom Core her kommt erst mit TYPO3 6.2.

    In 6.1 kannst du dir ggf. durch Installation von EXT:media behelfen, das weitere Felder an den FAL ranklebt, ich glaube auch eins für Mehrsprachigkeit.

    http://www.aemka.de/

  • Tom-iX Tom-iX
    Sternenflotten-Admiral
    0 x
    174 Beiträge
    0 Hilfreiche Beiträge
    07. 04. 2014, 12:31

    Danke dir.
    Die Extension media verwende ich schon, die bringt hier leider keine Abhilfe.
    Ja, es gibt noch keine vollständige fehlerfreie Lokalisierung in V6.1.7, habe ich auch schon gemerkt.
    Hole jetzt das "file-"-Objekt selber aus der Datenbank übersetze es, so funktioniert es auf jeden Fall.

    Grüße Thomas

    base iX. individual websolutions | http://www.base-ix.de

  • 1