[Frage] Resourcen Feld Images bei alternativer Seitensprache FAL Problem TYPO3-Version: 6.1.7

  • brainage brainage
    T3PO
    0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    28. 01. 2014, 15:26

    Hallo ich nehme das Resourcenfeld der Seiteneigenschaften um ein Hintergrundbild für die Seite zu erstellen. Das funktioniert auch ganz gut mit :

    1. temp.bgImage = FILES
    2. temp.bgImage {
    3. references {
    4. table = pages
    5. uid.data = page:uid
    6. fieldName = media
    7. }
    8.  
    9. renderObj = TEXT
    10. renderObj {
    11. data = file:current:publicUrl
    12. wrap = style="background:url('/|') no-repeat center bottom; min-height: 200px;"
    13. treatIdAsReference = 1
    14. }
    15. }

    Leider wird bei der alternativen Seitensprache auch das Bild der Standardsprache angezeigt und ich
    weiß nicht warum ?

    kann hier jemand helfen bzw. sollte es eigentlich funktionieren ?


  • 1
  • brainage brainage
    T3PO
    0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    30. 01. 2014, 13:41

    hm .. also so funktioniert es bei mir.
    aber es kommt mir nicht ganz richtig vor kann mir jemand was dazu sagen ?

    1. temp.bg = FILES
    2. temp.bg {
    3. references {
    4. listNum = 0
    5. data = levelmedia:-1
    6. }
    7.  
    8. renderObj = TEXT
    9. renderObj {
    10. data = file:current:publicUrl
    11. wrap = style="background:url('/|') no-repeat center bottom; min-height: 200px;"
    12. treatIdAsReference = 1
    13. }
    14. }

    das data ist natürlich data = file:current: publicUrl (ohne leerzeichen)
    danke

  • 1