[Frage] mailformular scrollt zu weit nach oben TYPO3-Version: 6.1.1

  • andres andres
    Jedi-Meister
    0 x
    500 Beiträge
    0 Hilfreiche Beiträge
    26. 01. 2014, 15:54

    guten tag
    ich habe auf: http://into-the-blue.ch/reise/ das mailformular am laufen. füllt der absender die pflichtfelder nicht aus und sendet das formular ab, springt die seite nach oben (kopf der seite) und das formular verschwindet. die warnhinweise «Plichtfeld» sind dann nicht mehr direkt sichtbar und der absender denkt das formular sei abgeschickt.
    frage: wie kann ich diesen effekt verhindern damit die eingabemaske stehen bleibt.
    bester gruss andré


  • 1
  • toifel toifel
    Jedi-Ratsmitglied
    0 x
    831 Beiträge
    96 Hilfreiche Beiträge
    31. 01. 2014, 13:41

    Dein Form Tag müsste folgendermaßen umgebaut werden:

    1. <form action="die-reise/#c18" class="formular" enctype="multipart/form-data" method="post">
    2. ...
    3. </form>

    Der Wrap deiner Form hat die ID "c18", durch das anhängen von #c18 an die Form-Url springt die Seite direkt zu diesem Element.

  • andres andres
    Jedi-Meister
    0 x
    500 Beiträge
    0 Hilfreiche Beiträge
    31. 01. 2014, 20:05

    hallo
    besten dank für deinen tip.
    kannst du mir sagen wo ich die entsprechende datei finde.

  • andres andres
    Jedi-Meister
    0 x
    500 Beiträge
    0 Hilfreiche Beiträge
    02. 02. 2014, 17:36

    scheint mir nicht so einfach zu sein dies umzubauen. ich weiss auch nicht genau wo ich das machen müsste. kannst du mir auf die sprünge helfen?
    dank und gruss
    andré

  • 1