[Frage] felogin macht nach erfolgreichem login keinen redirect auf angegebene Seite TYPO3-Version: 4.6.18

  • bah2 bah2
    TYPO3-Anwärter
    0 x
    7 Beiträge
    0 Hilfreiche Beiträge
    02. 01. 2014, 12:51

    Hallo!

    Ich habe eine Seite unter Typo 4.6.18 mit felogin 1.4.0 laufen. Benutzer, die sich dort anmelden, sollen nach erfolgreicher Anmeldung auf eine geschützte Seite "Mitglieder Begrüßung" in einem geschützten Mitgliederbereich mit weiteren Inhalten weitergeleitet werden. Das klappt leider nicht, die Weiterleitung erfolgt zur Startseite. Bei einem anderen Projekt, das allerdings unter Typo 4.5.6 läuft, klappt das auch wie in felogin angegeben. Bei der 4.6.18-Version werden die identisch bei felogin gemachten redirect-Angaben ignoriert.

    Ich habe jetzt schon einige Zeit in die Recherche zur Lösung reingesteckt und dabei erfahren, dass es sich dabei wohl um einen bug bei der 4.6er Version handeln soll. Gibt es dafür mittlerweile eine Lösung (felogin ist ja aktuell) bzw. kann das das Problem anderweitig fixen? Mit Typoscript habe ich leider nur wenig Erfahrung. Mittwald habe ich heute auch schon mal angerufen aber von dort gab es nur den Tipp, die Aktualität der Extension zu prüfen. Auch einen kostenpflichtigen Support gibt es dazu nicht.

    Wäre echt prima, wenn jemand dazu eine Idee hätte. Die Seite ist für einen Kunden gemacht worden der natürlich die Weiterleitung gerne hätte. Vielen Dank schon mal im voraus.


  • 1
  • Schweriner Schwerine...
    Jedi-Ratsmitglied
    0 x
    554 Beiträge
    60 Hilfreiche Beiträge
    02. 01. 2014, 13:21

    Bindest Du den Login per Typoscript oder als Plugin ein? Falls Plugin: Stell sicher, dass Du keinen Haken bei "Disable Redirect" oder wie auch immer das heißt gesetzt hast. Falls die Einstellungen alle korrekt sind und es sich wirklich um einen Bug handelt, könntest Du auf der Seite mit dem Login ein Erweiterungstemplate erstellen und dort folgendes eintragen um eine Weiterleitung zu erzwingen:

    1. config.additionalHeaders = Location: /index.php?id=2
    2. [global]

    Und dort dann die ID auf die Du weiterleiten möchtest.

  • bah2 bah2
    TYPO3-Anwärter
    0 x
    7 Beiträge
    0 Hilfreiche Beiträge
    02. 01. 2014, 14:19

    Super, vielen Dank für den Tipp. Ich bin gerade auf dem Sprung, probiere das aber gleich heute abend aus. Das Login wird über felogin realisiert und die Einstellungen dort identisch mit der funktionierenden Seite unter Typo 4.5.

    Ich melde mich heute abend nochmal...

  • Schweriner Schwerine...
    Jedi-Ratsmitglied
    0 x
    554 Beiträge
    60 Hilfreiche Beiträge
    02. 01. 2014, 15:19

    Existiert die Seite auf die weitergeleitet werden soll denn auch in dem neueren System, wenn alle Einstellungen identisch sind? :P

  • bah2 bah2
    TYPO3-Anwärter
    0 x
    7 Beiträge
    0 Hilfreiche Beiträge
    02. 01. 2014, 18:51

    Hat leider noch nicht funktioniert. Ich habe das Erweiterungstemplate für die loginseite erstellt, dort dein TS eingegeben und die ID der Seite im geschützten Mitgliederbereich eingetragen, auf die weitergeleitet werden soll. Hat so aber leider nicht funktioniert und wird anscheinend vollkommen ignoriert. Ich habe dann noch explizit die usergroup IDs angegeben und auch mal einen redirect in eine Seite im offenen, also nicht geschützten, Frontendbereich versucht. Daran hat es aber nicht gelegen. Cache habe ich auch gelöscht.

    Das Erweiterungstemplate besteht jetzt nur aus den 3 Zeilen von Dir und wie angegeben bei der Seiten-ID modifiziert. Noch eine Idee?

  • bah2 bah2
    TYPO3-Anwärter
    0 x
    7 Beiträge
    0 Hilfreiche Beiträge
    04. 01. 2014, 16:55

    Ich habe jetzt selbst die Lösung gefunden:
    Die loginseite war in einem Menübereich "Top" lokalisiert. Die Weiterleitung nach erfolgreichem login sollte aber auf eine Seite in einem 2. Menübereich "Inhalt" gehen. Aus welchen Gründen auch immer klappt das aus diesem grund nicht. Ich habe jetzt die loginseite und die Seite, auf die weitergeleitet werden soll, in einem Menübereich untergebracht und alles klappt so wie es soll.

    Vielleicht hilft das ja irgendeinem anderen Typo3newbie bei der Suche nach einer Lösung.

  • 1