06. 12. 2013, 09:33

Hallo ins Forum,
ich bin momentan an einem Problem bei dem Ich leider nicht mehr weiter komme.
Es geht um das Zusammenbauen von Links im RSS-feed von tt_news.

Die Webseite ist so aufgebaut das es eine EU-Seite gibt die auf die unterschiedlichen Länder weiterleitet. Es gib DE in deutsch / CH in deutsch, französisch und italienisch, und FR in französisch
es funktioniert soweit auch alles, es können alle News in den unterschiedlichen sprachen angezeigt werden und auch alle RSS-feeds. Mein Problem besteht beim Zusammenbau der Links im RSS-feed.

zuerst wurde sowas gebaut:
http://xxx.eu//de/unternehmen/neuigkeiten
http://xxx.eu//fr/unternehmen/neuigkeiten
http://www.xxx.eu//ch-de/unternehmen/neuigkeiten
http://www.xxx.eu//ch-fr/unternehmen/neuigkeiten
http://www.xxx.eu//ch-it/unternehmen/neuigkeiten

durch die Angabe von config.absRefPrefix = http://www.xxx.eu/ in den Setupeinstellungen der Länder
konnte ich leider nur den Fehler bei de und fr beheben.

Im ch zweig z.B. mit italienisch wird mir nun so ein link gebaut

http://www.xxx.eu/it_CH/ch-de/unternehmen/neuigkeiten/

ich vermute das es was mit der Mehrsprachigkeit zu tun hat da es nur im ch Zwei drei Sprachen gibt
hat jemand vielleicht eine Idee woher der Wert it_CH kommen kann?

Im SETUP für Sprachen hab ich sowas verwendet:

#Sonderloesung italienisch CH
[globalVar = GP:L=2]
config.linkVars = L
config.sys_language_uid = 2
config.language = it-CH
config.locale_all = it_CH.utf8
config.htmlTag_setParams = lang= it-CH
[global]

Vielen Dank für Hilfe.

Jürgen