[Frage] [FRAGE] irfaq :: SITE_REL_PATH eingefügt in Template/Quelltext TYPO3-Version: 4.5.27

  • mobilat mobilat
    T3PO
    0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    11. 11. 2013, 14:11

    Hallo zusammen,
    ich habe bei einem Projekt TYPO3 4.5.30 die Extension "irfaq" eingebunden.
    Im Quelltext wird zweimal JS und CSS eingebunden, je einmal mit SITE_REL-PATH.

    1. <link rel="stylesheet" href="###SITE_REL_PATH_AZ###res/irfaq_az.css" />
    2. <script type="text/javascript" src="typo3conf/ext/irfaq/res/toggleFaq.js"></script>
    3.  
    4.  
    5. <link rel="stylesheet" href="typo3conf/ext/irfaq_az/res/irfaq_az.css" />
    6. <script type="text/javascript" src="###SITE_REL_PATH###res/toggleFaq.js"></script>

    Ich habe das Standard-Template von irfaq gewählt, das statische Template eingebunden. Alles läuft, nur wirft mir der Internet Explorer einen Fehler ... der IE kommt mit dem ###SITE_REL_PATH### nicht klar. Seitenaufbau dauert ewig und der JS-Fehler wird angezeigt. So kann ich es nicht lassen.

    Frage: Wo schreibt die Extension den headerContent (js/css) rein und warum das Ganze zweimal? Wo kann ich den SITE_REL_PATH angeben.

    Hier mein TS dazu ..

    1. plugin.tx_irfaqaz_pi1 {
    2. numberOfColumns = 2
    3. # templateFile = fileadmin/templates/tmpl/faq_html_template.html
    4. }

    Anhänge (1)
    Bildschirmfoto 2013-11-11 um 14.10.55.png image/png 0,00 B 168 heruntergeladen

  • 1
  • mobilat mobilat
    T3PO
    0 x
    26 Beiträge
    0 Hilfreiche Beiträge
    11. 11. 2013, 15:58

    Glaube das hängt damit zusammen ,dass zum einen "irfaq" und irfaq_az" eingebunden ist.
    Habe jetzt im Template einfach den marker ersetzt mit "typo3conf/ext/irfaq/res/toggleFaq.js" bzw. "typo3conf/ext/irfaq_az/res/irfaq_az.css"

    jetzt wird es doppelt eingebunden, aber die Fehlermeldung ist weg.

  • 1