[Frage] OpenSSL extension not working TYPO3-Version: 6.1.0

  • Medi13 Medi13
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    30. 09. 2013, 12:31

    OpenSSL extension not working

    Ich bin blutiger Anfänger in der Programmierwelt, aber ich will für meine neue Website als CMS Typo3 einrichten.
    Leider habe ich noch Windows Vista. Bisher habe ich nur den Wamp-Server installiert. PHP, SQL und MyPhpAdmin laufen. Alles einwandfrei, läuft allerdings nicht über Port 80. Installation von Typo3 hat auch geklappt, aber jetzt hänge ich bei der Konfiguration von Typo3 fest: OpenSSL funktioniert nicht. Das Install Tool von Typo3 meldet: „OpenSSL extension not working. Something went wrong while trying to create a new private key. Please check your OpenSSL integration to verify the extension is installed correctly.”

    Aber ich sehe nicht, warum. Ich hab schon sämtliche Forenbeiträge duchforstet.
    1. Apache modules „ssl_module“ ist aktiv. Der Haken ist gesetzt.
    2. PHP extension „php_openssl“ ist auch aktiv. Haken ist gesetzt.
    3. Bei Typo3 im Ordner „sysext“ sind die Ordner „rsaauth“ und „saltedpasswords“ vorhanden.
    4. In der php.ini steht vor „extension=php_openssl.dll“ KEIN Semikolon.

    Bei Typo3 in der Konfiguration sieht das so aus:
    1) [BE][loginSecurityLervel]= rsa

    2) [FE][loginSecurityLevel]= rsa

    Das Problem mit OpenSSL ist der einzige Punkt, der mir bei der Konfiguration noch fehlt. Sehr ärgerlich! Hat jemand eine Idee?

    Danke für eure Hilfe!

    Medi

    Anhänge (3)
    warning_openssl.jpg image/jpeg 0,00 B 579 heruntergeladen
    BE_rsa_install.jpg image/jpeg 0,00 B 607 heruntergeladen
    FE_rsa_install.jpg image/jpeg 0,00 B 589 heruntergeladen
  • Hilfreichster Beitrag

  • alainreymond alainreym...
    Typ im Roten Hemd
    1 x
    1 Beiträge
    1 Hilfreiche Beiträge
    14. 06. 2014, 12:23 - Hilfreichster Beitrag

    Hallo,
    Nur für Information : ic hatte das selbe Problem mit Xampp 1.8.3 unter Win 7 64 bits, um Typo3 6.2.3 zu installieren. Da kam immer das Fehler das Openssl nicht funktionniert.
    Nach Versuch habe ich gesehen dass openssl.exe die Datei openssl.cnf immer in C:\openssl-1.0.1g\ssl suchte obwohl OPENSSL_CONF konfiguriert war.
    Ich habe also
    C:\openssl-1.0.1g\ssl erstellt,
    und C:\xampp\apache\conf\openssl.cnf kopiert.
    Mirakel ! Es hate funktionniert.
    Obwohl nicht perfekt, ist es nicht schlim für ein Test Konfiguration und kann vielleciht jemand helfen.

    mfg
    Alain
    PS : ich entschuldige für meinen sehr Deutsch!


  • Medi13 Medi13
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    12. 10. 2013, 18:13

    Habe den Fehler selbst gefunden: Installiert war nur die .exe, aber nicht das Programm OpenSSL selbst. Also Programm runtergeladen, installiert - et voilá: Die Fehler-Meldung hat sich erledigt!

  • lilalili lilalili
    T3PO
    0 x
    16 Beiträge
    0 Hilfreiche Beiträge
    12. 11. 2013, 09:49

    Hallo!
    Ich habe auch das selbe Problem. Habe versucht OpenSSL zu installieren, hier http://slproweb.com/products/Win32OpenSSL.html habe ich Win64 OpenSSL v1.0.1e Light runtergeladen und installiert.Das hilft aber nichts. Muss mann vielleicht noch was konfigurieren?
    Ich nutze xampp v3.2.1 Typo3 6.1.5
    Habe schon probiert, typo3 6.0.10 zu installieren. Alles OK. Möchte aber die neueste Version versuchen.
    Vielen Dank!

  • Medi13 Medi13
    TYPO3-Anwärter
    0 x
    5 Beiträge
    0 Hilfreiche Beiträge
    12. 11. 2013, 10:07

    Ansonsten hab ich nach der Installation von OpenSSL nur das Install Tool von Typo3 geschlossen, den Server einmal runtergefahren, neugestartet und das Install Tool wieder aufgerufen. Die sonstigen Einstellungen stimmen?
    Zur Erinnerung:
    1. Apache modules „ssl_module“ ist aktiv. Der Haken ist gesetzt.
    2. PHP extension „php_openssl“ ist auch aktiv. Haken ist gesetzt.
    3. Bei Typo3 im Ordner „sysext“ sind die Ordner „rsaauth“ und „saltedpasswords“ vorhanden.
    4. In der php.ini steht vor „extension=php_openssl.dll“ KEIN Semikolon.

  • Ning Ning
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    25. 12. 2013, 01:32

    Hi,

    ich hatte das Problem mit OpenSSL und XAMPP.

    habe ich Win64 OpenSSL v1.0.1e Light runtergeladen und installiert

    Irgendwo habe ich gelesen, dass die 1.0.1 von PHP und/oder Apache nicht unterstützt wird. Die nutzen scheinends noch die 0.9.8.

    Zusätzlich mußte ich OpenSSL noch in den Windows Systemvariablen eintragen. Siehe hier: [url]http://blog.joergboesche.de/xampp-1-7-7-apachephp-openssl-modul-workaround-gegen-abstuerze[/url]
    Jetzt kann ich daheim endlich auch mal die 6.2beta antesten :)
    In diesem Sinne fröhliche Weihnachten

  • ReinHol ReinHol
    Typ im Roten Hemd
    0 x
    3 Beiträge
    0 Hilfreiche Beiträge
    04. 01. 2014, 17:31

    Hallo,
    nachdem ich alle mögliche Tipps ausprobiert habe, haben mir die Infos von der folgende Site geholfen:[url]http://www.dynamic-webpages.de/php/ref.openssl.php[/url].
    Gruß
    Reinhold

  • kanticus kanticus
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    15. 01. 2014, 09:43

    Ich grüße Euch,

    hatte das Problem auch. Mir half http://wiki.typo3.org/Exception/CMS/1318283565
    Es fehlte nur der Pfad zur openssl.exe.

    Also:

    Set $TYPO3_CONF_VARS['SYS']['binSetup'] to the executable. E.g. 'openssl=C:/ ... /openssl.exe'
    If your path to openssl.exe contains blanks, make sure to quote the openssl parameter, e.g. 'openssl="C:/ ... /openssl.exe"'
    Danach ging es.
    Gruß
    Martin

  • alainreymond alainreym...
    Typ im Roten Hemd
    1 x
    1 Beiträge
    1 Hilfreiche Beiträge
    14. 06. 2014, 12:23

    Hallo,
    Nur für Information : ic hatte das selbe Problem mit Xampp 1.8.3 unter Win 7 64 bits, um Typo3 6.2.3 zu installieren. Da kam immer das Fehler das Openssl nicht funktionniert.
    Nach Versuch habe ich gesehen dass openssl.exe die Datei openssl.cnf immer in C:\openssl-1.0.1g\ssl suchte obwohl OPENSSL_CONF konfiguriert war.
    Ich habe also
    C:\openssl-1.0.1g\ssl erstellt,
    und C:\xampp\apache\conf\openssl.cnf kopiert.
    Mirakel ! Es hate funktionniert.
    Obwohl nicht perfekt, ist es nicht schlim für ein Test Konfiguration und kann vielleciht jemand helfen.

    mfg
    Alain
    PS : ich entschuldige für meinen sehr Deutsch!

  • 0 x
    23 Beiträge
    0 Hilfreiche Beiträge
    21. 08. 2014, 09:43

    Hi,

    ich hatte auch das Problem mit OpenSLL. Folgende Anleitung hat mir da weitergeholfen [url]http://alkunmedia.com/blog/installation-von-typo3-cms/[/url]

  • tangro-dop tangro-do...
    Jar Jar Binks
    1 x
    1 Beiträge
    1 Hilfreiche Beiträge
    12. 01. 2015, 10:48

    Hallo zusammen,
    ich hatte bis gerade eben auch Probleme mit OpenSSL und der neusten TYPO3-Version und der neusten XAMPP-Version. Hatte zuvor XAMPP geupdatet, da ich Backend-Probleme bekam, wenn ich TYPO3-6.2.9 installieren wollte (vermutlich hatte das mit der Datenbank und der neuen Verschlüsselung zu tun?!). Auf jedenfall dachte ich es liegt an XAMPP und habe das erstmal geupdatet.
    Anschließend habe ich (egal was ich eingestellt habe) immer fehlende OpenSSL-Meldungen bekommen.

    Was mir schlussendlich geholfen hat war Alain's Hinweis: Und zwar sucht die lokale Installation von OpenSSL im XAMPP-Ordner unter Windows den harten (?!) Pfad (bei mir:) C:\openssl-1.0.1i-win32\ssl\openssl.cnf
    Erstellt man diesen Ordner und kopiert die Datei hinein, wird OpenSSL endlich als funktionierend erkannt und man kann sich auch endlich ins TYPO3 Backend einloggen.

    Vielen Dank Alain für den Hinweis,

    viele Grüße,
    Dominik