[Frage] Seltsame überflüssige p-Tags / v6.1.4 TYPO3-Version: 6.1.1

  • 3dxO 3dxO
    R2-D2
    0 x
    122 Beiträge
    1 Hilfreiche Beiträge
    11. 09. 2013, 16:10

    Hallo,

    ich bin grade auf folgendes Problem gestoßen. Ich habe ein einfaches Text-Inhalts-Element erzeugt und wenn ich mir den Quelltext anschaue kommt so ein Schmu raus:

    1. <p>&nbsp;</p>
    2. <p> <!-- CONTENT ELEMENT, uid:1/text [begin] --></p>
    3. <p>&nbsp;</p><div id="c1" class="csc-default"><p>&nbsp;</p>
    4. <p> <!-- Text: [begin] --></p>
    5. <p>Hier kommt erst mein Text</p>
    6. <p> <!-- Text: [end] --></p>
    7. <p>&nbsp;</p></div><p> <!-- CONTENT ELEMENT, uid:1/text [end] --></p>
    8. <p>&nbsp;</p>

    Wie werde ich diese überflüssigen p-Tags los? Warum sind die da?
    Es ist ein frisch aufgesetztes Typo3 Version 6.1.4 und grad mal eine Test-Ausgabe.

    Bitte helft, sowas ist mir bisher in keiner anderen Typo3 Version über den Weg gelaufen.

    Gruß,
    Christian


  • 1
  • 3dxO 3dxO
    R2-D2
    0 x
    122 Beiträge
    1 Hilfreiche Beiträge
    12. 09. 2013, 08:23

    tja, lag wohl an meinem versuch fluidtemplate zu nutzen. ich habs jetzt wieder mit markern gelöst. das klappt wenigstens :)

    und mit diesem wissen stieß ich auch auf folgendes:
    <f:format.html [b]parseFuncTSPath="lib.parseFunc"[/b]>

    und nun klappt es auch mit fluidtemplate...

  • karlchen karlchen
    Jedi-General
    0 x
    1433 Beiträge
    30 Hilfreiche Beiträge
    13. 09. 2013, 15:03

    mit der 6.1.4 kannst du auch

    1. <f:format.raw></f:format:raw>

    nutzen, der "Umweg" über parseFuncTSPath, war in den vorhergehenden TYPO3 Versionen nur der WorkAround

  • 3dxO 3dxO
    R2-D2
    0 x
    122 Beiträge
    1 Hilfreiche Beiträge
    13. 09. 2013, 15:28

    danke :)

  • 3dxO 3dxO
    R2-D2
    0 x
    122 Beiträge
    1 Hilfreiche Beiträge
    13. 09. 2013, 15:29

    danke :)

  • 1