[Frage] SOLR Suche TYPO3-Version: 4.5.27

  • Greenhorn2013 Greenhorn...
    Sternenflotten-Admiral
    0 x
    255 Beiträge
    0 Hilfreiche Beiträge
    25. 07. 2013, 17:50

    Hallo zusammen,
    ich beschäftige mich gerade mit der Extension "solr" für die Einbindung von Apache Solr.
    Die Installation der Extension und von Tomcat und Solr hat soweit funktioniert. Über die Web Gui kann ich auch die einzelnen Cores sehen und Administrieren.

    Das Problem ist nur, das die Typo3 Extension "solr" keine Verbindung aufbauen kann.
    Ich habe die URL schon angepasst, und alle Einstellungen geprüft.
    Aber auf http://localhost:8080/solr-3.6.2/core-de_DE/ bekomme ich nur eine 404 Meldung obwohl http://localhost:8080/solr-3.6.2/core-de_DE/admin funktioniert.

    Hat jemand eine Idee?

    Tags: Solr

  • 1
  • vince vince
    Sternenflotten-Admiral
    0 x
    180 Beiträge
    6 Hilfreiche Beiträge
    26. 07. 2013, 12:08

    hallo,

    soweit ich weiß, sendet die Extension die Anfragen an den Solr-Server mit curl. In der php.ini muss das aktiviert sein, bzw. das Modul muss verfügbar sein.
    Also das ist das einzige, dass mir spontan als Fehlerquelle einfällt.

    DevLog kann hier auch helfen, die Solr Extension schreibt da so ziemlich alles rein (sofern es im TS so eingestellt ist).

    Gruß,
    Vince.

  • Greenhorn2013 Greenhorn...
    Sternenflotten-Admiral
    0 x
    255 Beiträge
    0 Hilfreiche Beiträge
    30. 07. 2013, 21:20

    Im Devolog stehen nur statusmeldungen aus class.t3lib_userauth.php, nix mit SOLR

    Debug ist eingeschaltet, aber ein debuggen der Verbindung ist nicht möglich :(

  • vince vince
    Sternenflotten-Admiral
    0 x
    180 Beiträge
    6 Hilfreiche Beiträge
    31. 07. 2013, 12:23

    was steht unter reports > status report ?
    zumindest in früheren Version der Extension stand da dann immer, ob die verbindung zum Solr-Server klappt oder nicht, auch mit Fehlermeldung.

  • 1