[Frage] Marker in E-Mails Powermail 2.0.6 [Gelöst] TYPO3-Version: 4.7.4

  • tommboogie tommboogi...
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    24. 07. 2013, 18:56

    Hallo zusammen,

    ich habe das Problem, dass Marker wie z.B. ###uid123### in der Absender E-Mail nicht mit dem Wert des entsprechenden Feldes in Powermail 2.0.6 ersetzt werden.

    Müssen die Marker in Verbindung mit Fluid anders benannt werden?

    Grüße TJ

  • tommboogie tommboogi...
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    25. 07. 2013, 14:57 - Lösung

    Hey Mischa, danke für den Hinweis!

    Es ist tatsächlich so, dass bei mehreren Checkboxen einfach der Index mit angehängt wird. Konkret sieht es so aus: {checkboxName.0} [checkboxName.1} {checkboxname.2} {...} wobei das erste Element den Index 0 hat.

    Grüße TJ

  • Hilfreichster Beitrag

  • mischa mischa
    Jedi-Meister
    1 x
    411 Beiträge
    5 Hilfreiche Beiträge
    25. 07. 2013, 08:52 - Hilfreichster Beitrag

    ja. Das geht jetzt mit {markerName}
    Den markernamen findest du in der jeweiligen Felddefinition

    LG,

    Mischa.


  • 1
  • mischa mischa
    Jedi-Meister
    1 x
    411 Beiträge
    5 Hilfreiche Beiträge
    25. 07. 2013, 08:52

    ja. Das geht jetzt mit {markerName}
    Den markernamen findest du in der jeweiligen Felddefinition

    LG,

    Mischa.

  • tommboogie tommboogi...
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    25. 07. 2013, 11:23

    Hey Mischa,

    danke für die Antwort, funktioniert =}

    Kannst Du mir jetzt noch sagen, wie ich Checkboxes eintrage, damit nicht "Array", sondern der seketierte Wert in der E-Mail steht?

    Danke & Grüße TJ

  • tommboogie tommboogi...
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    25. 07. 2013, 11:41

    Ok, ich habs slebst herausgefunden {checkboxName.0}, jedoch funktioniert es nur, wenn es sich um eine Checkbox handelt. Bei der Mehrfachauswahl, sprich wenn sich mehrere Optionen (Checkboxen) in einem einem Objekt befinden, wird lediglich das erste ausgewählte element übergeben, die anderen stehen nicht in der E-Mail :(

  • mischa mischa
    Jedi-Meister
    0 x
    411 Beiträge
    5 Hilfreiche Beiträge
    25. 07. 2013, 13:53

    Ich habe powermail 2 bis jetzt noch nicht so gut getestet.
    Ich kann mir aber vorstellen, dass du dann mit dem Zähler weiter machen musst {checkboxName.1} {checkboxName.2} etc.

    LG,

    Mischa.

  • tommboogie tommboogi...
    Padawan
    0 x
    38 Beiträge
    0 Hilfreiche Beiträge
    25. 07. 2013, 14:57

    Hey Mischa, danke für den Hinweis!

    Es ist tatsächlich so, dass bei mehreren Checkboxen einfach der Index mit angehängt wird. Konkret sieht es so aus: {checkboxName.0} [checkboxName.1} {checkboxname.2} {...} wobei das erste Element den Index 0 hat.

    Grüße TJ

  • 1