This user is not allowed access to the backend.

  • till till
    T3PO
    0 x
    17 Beiträge
    0 Hilfreiche Beiträge
    16. 05. 2004, 21:47

    Hallo Zusammen!

    Wenn ich einem Benutzer bei den Rechten auf "Edit Frontend Only" setze bekomme ich beim einloggen mit dem jeweiligen User immer nur:

    [quote:ed7d76c353]This user is not allowed access to the backend. [/quote:ed7d76c353]

    Wenn ich aber beim einloggen als Interface "Frontend" wähle, funktioniert es.

    D.H. der Benutzer hat die nötigen Rechte. Wieso funktioniert aber die automatische Umleitung zum Frontend nicht?

    Ich benutze Typo3 3.6.0 mit der aktuellen Edit Fronend Only - Extension.

    Danke für eure Hilfe!

    Grüsse aus Basel ( CH )


  • 1
  • TW TW
    Jedi-General
    0 x
    1560 Beiträge
    0 Hilfreiche Beiträge
    18. 05. 2004, 08:29

    hi
    sicher dass die extension richtig konfiguriert ist?
    ich kenne das teil zwar nicht, aber is doch etwas seltsam wenn diese fehlermeldung auftritt....

    handelt sich doch um ne frontend sache???!!! :o

    cu
    thorsten

  • downset downset
    Sternenflotten-Admiral
    0 x
    214 Beiträge
    0 Hilfreiche Beiträge
    22. 05. 2004, 00:06

    Habe das gleiche Problem. Hast Du schon ne Lösung gefunden?

    Gruß

    Jens

  • iceman19 iceman19
    T3PO
    0 x
    10 Beiträge
    0 Hilfreiche Beiträge
    26. 05. 2004, 16:26

    bei mir ist der selbe fehler. hat jemand eine lösung.
    habe bereits die extension verändert, wie es in anderen beiträgen geschrieben wurde. dadurch funzt zwar der rte, jedoch funktioniert die frontend only extension in der hinsicht nicht mehr, dass nach dem login wieder ins backend geleitet wird.

    hab außerdem das problem, dass ich im adminpanel einstellen kann was ich will. es hat keine auswirkung. es geht mir vor allem um die option des editierens im popup fenster.

  • yamo yamo
    TYPO3-Anwärter
    0 x
    4 Beiträge
    0 Hilfreiche Beiträge
    23. 06. 2004, 06:41

    Stehe vor der selben Hürde :-(

    Hat dieses Problem jetzt schon jemand gelöst oder nicht?


  • 0 x
    23. 06. 2004, 13:58

    Guckst du hier:
    http://www.typo3.net/viewtopic.php?t=7841&highlight=user+allowed+access+backend

    Bei mir hat es leider nicht ganz den erhofften Erfolg gebracht. Zwar kann ich mich nach der Änderung im Code einloggen, aber werde anschließend direkt zum Backend weitergeleitet. Irgendwo habe ich mal gelesen, dass das ein Versionskonflikt sein soll und es mit 3.5.x noch lief. Genau weiß ich es allerdings nicht.

    Gruß.

    PS: v3.6.1RC, CSS Styled Content v.0.1.0, TemplaVoila v0.2.0, RealURL v0.1.4

  • tanjob tanjob
    R2-D2
    0 x
    103 Beiträge
    0 Hilfreiche Beiträge
    13. 07. 2004, 13:59

    Hallo zusammen,

    Die Erweiterung frontend-editing-only-flag würde ich nicht benutzen. Ich hatte damit nur Probleme. Stattdessen habe ich das ganze wie folgt umgesetzt.

    Also:
    1. edit in frontend only flag NICHT ANKREUZEN

    2. in die erste zeile eures setups:
    [code:1:71e6c51bc4]config.admPanel=1[/code:1:71e6c51bc4]

    3. danach folgendes einfügen:
    [code:1:71e6c51bc4]
    temp.pageeditpanel = EDITPANEL
    temp.pageeditpanel.allow = new
    temp.pageeditpanel.label = Seite:<B>%s</B><br> Hier können Sie eine Unterseite zu dieser Seite anlegen
    temp.pageeditpanel.line = 4

    temp.addcontent = EDITPANEL
    temp.addcontent.label = Neuer Seiten-Inhalt<br> Hier können Sie einen Seiteninhalt einfügen
    #temp.addcontent.line = 5
    temp.addcontent.newRecordFromTable = tt_content

    seite.3 < temp.pageeditpanel
    seite.6 < temp.addcontent[/code:1:71e6c51bc4]

    4. in das TS feld eures users
    [code:1:71e6c51bc4]
    admPanel {
    hide=0
    enable.preview=0
    enable.edit=1
    module.edit.forceDisplayFieldIcons=0
    module.edit.forceNoPopup=1
    module.edit.displayIcons=1
    }
    [/code:1:71e6c51bc4]

    5. Tools>Installation>Edit file in typo3conf
    in localconf.php folgende Zeile
    [code:1:71e6c51bc4]
    $TYPO3_CONF_VARS["BE"]["interfaces"] = "alternative";
    [/code:1:71e6c51bc4]
    ändern in
    [code:1:71e6c51bc4]
    $TYPO3_CONF_VARS["BE"]["interfaces"] = "alternative,frontend";
    [/code:1:71e6c51bc4]
    6. den link müsst ihr irgendwo einbauen, also zb text "login" und diesen link drauf legen.

    typo3/index.php?redirect_url=../index.php?id=3

    so kommt euer benutzer zu der login maske und mit
    id= in meinem fall 3 gebt ihr die seite an auf die er zurückgeleitet werden soll.

    7. jetzt ausloggen und als der benutzer anmelden
    und im adminpanel die entsprechenden felder ankreuzen,
    also zb. enable edit, display icons, nopopup

    8. dann nochmal als admin anmelden und im ts feld des users
    [code:1:71e6c51bc4]hide = 1[/code:1:71e6c51bc4] setzen.

    so das wars, ich hoffe es klappt.
    Gruss tanjob

  • campanero campanero
    Padawan
    0 x
    41 Beiträge
    0 Hilfreiche Beiträge
    13. 07. 2004, 14:57

    hallo zusammen,

    was war eigentlich mit diesem Ansatz in "Edit in Frontend Only":

    [quote:49e0c44c63]Man muss folgendes ändern in der Datei:

    typo3conf/ext/frontend_edit_only/class.ux_t3lib_beuserauth.php

    if (TYPO3_MODE=="BE" ...

    ändern in

    if (TYPO3_MODE=="FE" ...
    [/quote:49e0c44c63]

    ...man bekommt zwar nicht mehr die "Fehlermeldung"
    landet aber auch wieder im Backend :(

    Hat jemand hierfür eine Lösung gefunden ???
    drehe mich hier nur im Kreis #evil#

    Dacht eigentlich, das diese Eigenschaft eine wichtiger Bestandteil von Typo3 ist, oder nicht?

  • 1