wt_directory: Fehlfunktion nach TYPO3-Update

  • kolki kolki
    Jedi-General
    0 x
    1044 Beiträge
    5 Hilfreiche Beiträge
    19. 04. 2013, 07:57

    Hallo liebe TYPO3-Gemeinde,

    ich benutze zur Darstellung von Adressinformationen die Extension wt_directory und war damit bisher sehr zufrieden.
    Nach einem längst fälligen TYPO3-Update, auf zunächst einmal 4.5x, fiel auf, dass wt_directory nicht mehr ganz das tut, was es soll:

    Zum einen sind im Frontend die Kategorien nur verfügbar, wenn man im Backend auch die Oberkategorie hinzufügt, was ja noch zu verschmerzen wäre.
    Viel ärgerlicher ist, dass die Suche über die unter "Such-Felder hinzufügen" hinzugefügten Felder keine Ergebnisse mehr liefern, außerdem werden die Eingabefelder im Frontend nicht mehr bezeichnet.

    Ein Blick in die deprecation.log verrät, dass die in der Extension verwendete Funktion rm_endcomma() seit TYPO3 4.5 veraltet ist. Viele Grüße an den Entwickler, vielleicht kann er das ja mal bei Gelegenheit reparieren... #paralyzed#
    In forge.typo3.org gibt es jede Menge weitere offene Bug-Einträge.
    Achso, forge.typo3.org verrät, statt rm_endcomma() die Funktion rtrim() zu nutzen (line 620 in class.wt_directory_div.php), was bei mir aber auch nicht funktionierte und das Problem nicht löste.


  • 1
  • kolki kolki
    Jedi-General
    0 x
    1044 Beiträge
    5 Hilfreiche Beiträge
    07. 05. 2013, 16:00

    Wer von Euch hat die Lösung des Problems oder aber nur einen Tipp, oder gibt es vielleicht Alternativen zu wt_directory?

  • 1