Hilfe beim File Upload

  • 0 x
    123 Beiträge
    0 Hilfreiche Beiträge
    19. 02. 2013, 11:42

    Hallo,
    ich habe mir ein Formular zum Hochladen von Bildern erstellt. Dazu habe ich mir dann noch einen Validator geschrieben, der per Annotation eingebunden wird z.B. @validate $object Tx_XYZ_Domain_Validator_Uploadvalidator. Ich habe das nun mal bei einem persistenten Objekt probiert. Das heißt, bei einer Firma die bereits in der Datenbank ist. Ich habe diese ausgelesen und übergebe das Objekt an das Formular. Das Upload Feld bekommt als property logo. Hier klappt alles wunderbar. Diese FEhlermeldungen sind immer korrekt. Ich möchte nun aber gerne noch einen Upload für einzelne Bilder. Dafür ertelle ich immer ein Objekt mit dem Objekt Manager und create. Diese Objekt übergebe ich dann an das Formular. Aber immer wenn ich es absende, bekomme ich die Meldung:
    Required property xyz does not exist. Das tritt aber nur auf, bei Objekten die noch nicht persistent sind. Hat einer irgendeine Idee was das sein könnte und wie ich das umgehen kann? Besten Dank Stefan


  • 1
  • 0 x
    123 Beiträge
    0 Hilfreiche Beiträge
    19. 02. 2013, 12:34

    Hallo,

    ich habe jetzt nochmal von allen Stationen ein Screen gemacht und stelle den hier mal ein. Vielleicht erkennt ja jmd den Fehler.

    Ich habe meine Actions,das Formular, den Quellcode, eine Debugausgabe eines erstellten Picture Objekts und die Fehlermeldung auf das Bild gepackt.

    Ich hoffe jmd. findet den Fehler. Danke.

    Es sieht so aus als ob das Picture Objekt nicht korrekt an die savepictureAction übergeben wird. deswegen fehlt es wohl. Aber warum?

    Anhänge (1)
    debug.png image/png 0,00 B 171 heruntergeladen
  • 1