Extension Builder: tt_content erweitern -> Error: No rendering Definition

  • Sir_Lunchalot Sir_Lunch...
    Typ im Roten Hemd
    0 x
    2 Beiträge
    0 Hilfreiche Beiträge
    01. 02. 2013, 09:37

    Guten Morgen!
    Ich beschäftige mich zurzeit mit Typo3 6 und dem Extension Builder.
    Ich habe eine simple Test-Extension erstellt, wenn ich sie mit einer eigenen Tabelle anlege, wird mir im Frontend auch alles ausgegeben. Sobald ich allerdings tt_content erweitere, damit ich es als Content Element auf der Seite einfügen kann, erhalte ich immer den bekannten gelben Fehler "ERROR: Content Element type "Tx_Test1_Test1" has no rendering definition!"

    Bei einer pibase Extension hat es immer geholfen einfach den Cache zu löschen, unter extBase schaffe ich es nicht, eine Extension als Content Element anzulegen, auch unter Typo3 4.7.7 erhalte ich genau das selbe Resultat.

    Kann mir jemand sagen wie ich eine Extension erstelle, in der ich tt_content erweitern kann, damit der Redakteur CE einfügen kann?
    Habe versucht das Typoscript der Extension im Root Template zu inkludieren, in einem Erweiterungstemplate zu inkludieren, direkt ins Setup bzw die Constants reingeschrieben, aber es hat alles nichts geholfen :/
    [IMG]http://i50.tinypic.com/64msl2.jpg[/IMG]
    [IMG]http://i45.tinypic.com/zodmiw.jpg[/IMG]

    Wäre sehr dankbar über Hilfe :)
    Falls ihr weitere Infos benötigt, bitte einfach sagen.


  • 1
  • 0 x
    19 Beiträge
    1 Hilfreiche Beiträge
    03. 06. 2013, 20:58

    Hallo,

    ich denke mal Du brauchst noch min. sowas im Extension oder Page Setup:

    1. tt_content.Tx_Test1_Test1 = TEXT
    2. tt_content.Tx_Test1_Test1....

    also eine TypoScript Config für Deine Extension.

    Schau evtl. mal via TypoScript ObjectBrowser
    im Baum nach

    tt_content.header...
    tt_content.text...
    tt_content.image...

    dort findest Du verschiedene Rendering Definitionen
    nach wobei "header" den CType wiederspiegelt.
    Ich hoffe das hilft ein bisschen.

  • 1