24. 10. 2012, 11:12

Ich hab ein Problem mit der Ext facebook_socialplugins

Mit der iFrame Integration kann ich den Link zwar liken, allerdings taucht dann immer die ROOT Page auf, was bei dem Projekt etwas unnütz ist.
Mit der "normalen" Variante wird der like Button zwar angezeigt und lässt sich klicken, allerdings verschwindet er danach auf der Seite komplett und auch der vermeintliche like taucht nicht auf Facebook auf. Dabei ist die Konfiguration richtig.

TS:

  1. plugin.tx_facebooksocialplugins_pi1 {
  2. type_form = like_button
  3. }
  4. plugin.tx_facebooksocialplugins_pi1.like_button {
  5. d_show_faces = 0
  6. d_verb = like
  7. d_width = 150
  8. d_height = 200
  9. d_layout_style = button_count
  10. d_send = 1
  11. d_show_in_iframe = 0
  12. }
  13.  
  14. temp.facebooklike < temp.facebook
  15.  
  16.  
  17. tx_comvosglobalmarkers {
  18. markers {
  19. facebooklike < plugin.tx_facebooksocialplugins_pi1
  20. }
  21. }

Constants

  1. plugin.tx_facebooksocialplugins.appID = 324541297653865
  2. plugin.tx_facebooksocialplugins.language = de_DE
  3. plugin.tx_facebooksocialplugins.templateFile = EXT:facebook_socialplugins/pi1/template.html

comvosglobalmarkers nutze ich in diesem Fall, weil ich in eine bestehende Extension (die ich nicht geschrieben habe) möglichst einfach einen Marker setzen und ersetzen lasse.

Frage ist auch in wie weit Links mit Parametern ein Problem mit der FB Extension sind, da das Plugin wo Facebook mit integriert werden soll nicht auf realURL angepasst worden ist. Entsprechend hängen da je nach Suche etc. extrem viele Parameter dran.